• Hey! Guest! The 37th GMC Jam will take place between May 28th, 12:00 UTC and June 1st, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows YYC running slower than VM

SQGTDev

Member
I swapped over to a new PC and just got Visual Studio 2017 so I could use the YYC.

Strangely, it was running as usual at first, but suddenly the framerate dipped even lower than VM.
Even stranger, this is affecting all my projects, which leads me to think that the problem isn't any of my code, but that something is wrong with either GMS2 or my VS installation.
I have an i7 now so my specs probably aren't an issue either! Has this happened to anyone else and is there anything I should try?
 

ph101

Member
Depending on the project, if its very intensive, check your gpu is kicking in eg in nvidia options. If its not gpu related, also you could look into various sleep margin settings and power saving settings on your pc.
 

SQGTDev

Member
Depending on the project, if its very intensive, check your gpu is kicking in eg in nvidia options. If its not gpu related, also you could look into various sleep margin settings and power saving settings on your pc.
I tried everything you mentioned, and in the end it was my power saving settings causing it. I set it to high performance and it fixed the bottlenecks entirely. Thank you!
 

ph101

Member
I tried everything you mentioned, and in the end it was my power saving settings causing it. I set it to high performance and it fixed the bottlenecks entirely. Thank you!
Great! Out of interest can you share what settings you changed from and to in order to fix this? Details of the laptop would be interesting too.
 

SQGTDev

Member
Great! Out of interest can you share what settings you changed from and to in order to fix this? Details of the laptop would be interesting too.
No prob, sorry for the late reply.

I'm actually using a desktop, I included a pic of my PC specs. I changed the power settings from HP recommended to High performance.

After that I actually dumped like 300 enemies in a room just to test the framerate, and I noticed that below like 500fps, the YYC framerate started to stay consistently higher. My theory is that the fps was lower because my PC was rendering the frames quickly enough to give it time to "sleep," so it would only need to exert itself more when the framerate actually got low enough to potentially threaten my 60fps. Don't quote me on that though!
 

Attachments

ph101

Member
My theory is that the fps was lower because my PC was rendering the frames quickly enough to give it time to "sleep," so it would only need to exert itself more when the framerate actually got low enough to potentially threaten my 60fps. Don't quote me on that though!
Yeah I thought it might something along those lines also. Do you have default sleep margin settings?
 
Last edited:
Top