Linux YYC on linux doesn't work?

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Goldoche, Sep 30, 2019.

Tags:
  1. Goldoche

    Goldoche Member

    Joined:
    Dec 30, 2016
    Posts:
    36
    VM works fine for me on Windows and Ubuntu.
    YYC works fine for me on Windows.

    But I cannot run or create an executable using YYC on linux. I already have all the libraries listed here:

    https://help.yoyogames.com/hc/en-us/articles/235186168-Setting-Up-For-Ubuntu

    I have Ubuntu LTS 18.04.3 64bits on the target machine.

    Here's my console output.
    Again, I don't have any problems using the VM option when building or running for linux. There's no issues with connectivity when choosing that option.
     
    Last edited: Sep 30, 2019
  2. Zhanghua

    Zhanghua Member

    Joined:
    Aug 3, 2017
    Posts:
    169
    So you may check this file:
    : scp: /home/brun/GameMakerStudio2/yyc/typeknight/typeknight: No such file or directory
     
  3. Goldoche

    Goldoche Member

    Joined:
    Dec 30, 2016
    Posts:
    36
    It seems like the executable file isn't created properly. I can't do anything about that.
     
  4. MusNik

    MusNik Member

    Joined:
    Jun 21, 2016
    Posts:
    140
    That looks weird.

    Try to restart connection with Linux computer, restart the IDE, clean the project with 'broom" button and compile with YYC without trying to compile with VM.
     
  5. Goldoche

    Goldoche Member

    Joined:
    Dec 30, 2016
    Posts:
    36
    I did all of that and more. After 6 hours I give up. Honestly, unless someone else with the same current version can confirm YYC works for them on linux I think the problem is on YoYo's end.
     
  6. Zhanghua

    Zhanghua Member

    Joined:
    Aug 3, 2017
    Posts:
    169
    Is the empty project can be compiled?
     
  7. frico

    frico Member

    Joined:
    Oct 3, 2019
    Posts:
    1
    Had a similar issue when trying to create a Linux build (hosting Ubuntu LTS 18.04.3 64bit in VirtualBox on Windows 10).

    The VM option worked fine, both for starting directly in GM and for exporting a .zip file. The YYC option on the other hand created a similar, but not identical output as in OP, notice for example the lack of the
    warning. But the "client already connected" issue seems to be the same:
    Code:
    X://bin/GMAssetCompiler.exe DONE (0)
     [ -d "/home/frico/GameMakerStudio2/yyc/FromPC/Empty" ] || mkdir -p "/home/frico/GameMakerStudio2/yyc/FromPC/Empty"
    pscp Y:\Empty_5143607E_YYC\GameAssetsLinux.zip /home/frico/GameMakerStudio2/yyc/FromPC/Empty/
    pscp Y:\Empty_5143607E_YYC\YYGML.h /home/frico/GameMakerStudio2/yyc/FromPC/Empty/
    pscp Y:\Empty_5143607E_YYC\Ref.h /home/frico/GameMakerStudio2/yyc/FromPC/Empty/
    pscp Y:\Empty_5143607E_YYC\YYStd.h /home/frico/GameMakerStudio2/yyc/FromPC/Empty/
    pscp Y:\Empty_5143607E_YYC\libyoyo_yyc-x64.a /home/frico/GameMakerStudio2/yyc/FromPC/Empty/
    pscp Y:\Empty_5143607E_YYC\makefile /home/frico/GameMakerStudio2/yyc/FromPC/Empty/
    pscp X:/linux\execute.sh /home/frico/GameMakerStudio2/yyc/FromPC/Empty/
    cd /home/frico/GameMakerStudio2/yyc/FromPC/Empty; chmod +x execute.sh
    pscp Y:\Empty_5143607E_YYC\Game\ /home/frico/GameMakerStudio2/yyc/FromPC/Empty/Game
    rsync -c -r /home/frico/GameMakerStudio2/yyc/FromPC/Empty /home/frico/GameMakerStudio2/yyc
    cd /home/frico/GameMakerStudio2/yyc/Empty && make -j `nproc --all`
    WARNING: Unable to connect to remote client: ssh command 'cd /home/frico/GameMakerStudio2/yyc/Empty && make -j `nproc --all`' failed.
    bash: make: command not found
    
    WARNING: Unable to connect to remote client: The client is already connected.
    pscp /home/frico/GameMakerStudio2/yyc/Empty/Empty Y:\Empty_5143607E_YYC\package\Empty
    Renci.SshNet.Common.ScpException: scp: /home/frico/GameMakerStudio2/yyc/Empty/Empty: No such file or directory
       bei Renci.SshNet.ScpClient.ReadString(Stream stream)
       bei Renci.SshNet.ScpClient.InternalDownload(IChannelSession channel, Stream input, FileSystemInfo fileSystemInfo)
       bei Renci.SshNet.ScpClient.Download(String filename, FileInfo fileInfo)
       bei ..(String , String )
       bei Igor.LinuxBuilder.pscp_from(String remote, String local)
       bei Igor.LinuxBuilder.Package()
    Igor complete.
    elapsed time 00:00:11.7647874s for command "C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.2.3.344/bin/Igor.exe" -j=8 -options="C:\Users\Rico\AppData\Local\GameMakerStudio2\GMS2TEMP\build.bff" -v -- Linux Package started at 10/03/2019 20:23:00
    "cmd"  /c subst Z: /d
    
    elapsed time 00:00:00.0605119s for command "cmd" /c subst Z: /d started at 10/03/2019 20:23:12
    "cmd"  /c subst Y: /d
    
    elapsed time 00:00:00.0556318s for command "cmd" /c subst Y: /d started at 10/03/2019 20:23:12
    "cmd"  /c subst X: /d
    
    elapsed time 00:00:00.0546561s for command "cmd" /c subst X: /d started at 10/03/2019 20:23:12
    FAILED: Package Program Complete
    Note: "bei" means "at". The rest of the message should be in English.
    As you may have read from the file path, that was actually used on a new, empty project. Empty apart from what GM creates by default (like a first room). So to answer your question, @Zhanghua: it didn't change anything compared to a real project I tried to export to Ubuntu with the YYC option.

    I looked up a thread from last year which seemed to have a similar problem and suggested removing special characters like ' from strings, but that didn't change anything, either...not in the real project and not in the empty project which didn't have any strings to begin with.
     
    Goldoche likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice