Windows YYC: Failed to launch debugger: yydebug file missing:

Discussion in 'Legacy GameMaker Community Tech Support' started by Oldnice, Jan 1, 2019.

  1. Oldnice

    Oldnice Member

    Joined:
    Aug 3, 2017
    Posts:
    2
    Trying to compile windows project fails. When running "normally", the AssetCompiler crashes. When running in debug, the following error is output in the build console:
    "Failed to launch debugger: yydebug file missing:"

    Despite the colon, there is no further information about the error. I'm using a VS 2012 installation that has previously worked. Creating a new clean project results in the same errors. Googling this error results in no hits.

    Without YYC compilation, the game runs successfully.

    Anyone know how to start troubleshooting this? I don't know what the yydebug file is (compiler debug info?) or why it's missing.
     
  2. Oldnice

    Oldnice Member

    Joined:
    Aug 3, 2017
    Posts:
    2
    So here's what I've found so far:
    Running the game without the (YYC) compiler successfully generates a .yydebug file, and the game runs successfully. However, running with the YYC compiler, the GMAssetCompiler.exe fails to generate a .yydebug-file, which seems to disable the debugger and stalls the game, which is waiting for the debugger to connect. Now I'm not sure whether the YYC compiler is actually used when running in debug mode, but since the yydebug-file is nowhere to be found, debugging with YYC configuration is not possible.

    Good news though: I was able to make the non-debug YYC compiler work. Process monitor indicated that the compiler was searching for rc.exe and mt.exe (Visual Studio and Windows SDK files), which it could not locate. Locating & copying these to the "Microsoft Visual Studio 12.0\VC\bin" folder worked. This is not a correct folder for these binaries, but since it was searching them in any environment variable location, and the vcvars32.bat sets the VS12.0 folder as environment variable, this seemed to be a decent location for the files.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice