• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows YoYo Compiler "FAILED: Run Program Complete"

Minerkey

Member
encountered an odd problem with the YoYo compiler - maybe someone can help shed some light on it? It'd be appreciated :D

It compressed textures and ran fine up until the very end - so I'm just showing this last part

Writing Chunk... AUDO
-----------------------------------------------------------------------------
System.ArgumentException: An item with the same key has already been added.
at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
at GMAssetCompiler.Output.LLVM_Windows.(String )
at GMAssetCompiler.Output.LLVM_Windows..ctor()
at ..()
at ..(GMAssets , String )
at GMAssetCompiler.Program.(GMAssets )
at GMAssetCompiler.Program.(String[] )
-----------------------------------------------------------------------------
EXCEPTION FILE - C:\Users\User\AppData\Local\Temp\4dbe198027f84de39125d1823c8d3289.yyg.saencryptedreport
-----------------------------------------------------------------------------
C:\WINDOWS\system32\cmd.exe exited with non-zero status (-532462766)
elapsed time 00:02:11.2269233s for command "C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.2.5.378/bin/Igor.exe" -j=8 -options="C:\Users\User\AppData\Local\GameMakerStudio2\GMS2TEMP\build.bff" -v -- Windows Run started at 12/21/2019 10:56:58
"cmd" /c subst Z: /d
elapsed time 00:00:00.0550120s for command "cmd" /c subst Z: /d started at 12/21/2019 10:59:09
"cmd" /c subst Y: /d
elapsed time 00:00:00.0470098s for command "cmd" /c subst Y: /d started at 12/21/2019 10:59:09
"cmd" /c subst X: /d
elapsed time 00:00:00.0460108s for command "cmd" /c subst X: /d started at 12/21/2019 10:59:09
FAILED: Run Program Complete
For the details of why this build failed, please review the whole log above and also see your Compile Errors window.
Help would be appreciated - as I think using YYC to compile will probably solve some of the issues I've been having performance wise.

Thanks ^-^
 

DatZach

Member
The exception message is claiming that an key of the same name is being added. There's a lot of things that could mean.
Try the following:
  • Clean your cache (click the Brush icon next to the Stop icon), then rebuild
  • Check your Sound resources to make sure that you don't have anything with the same name OR audio files with the same filename in any Sounds
If none of that works, you should file a formal bug report with YYG (Be prepared to attach your project, or something that reproduces the issue).
https://accounts.yoyogames.com/contact-us#select
 

Japster

Member
@Minerkey @PeachPieProductions - This may NOT be related, but what have you got to lose?:-

I got VERY similar, weird exceptions / failures after the AUDO stage too ages ago. Tried lots of stuff, until someone suggested I temporarily switch runtimes (download one if you need to, from inside GMS2) - then restart, and switch back to your preferred one.

NOTHING else worked for me, even cleaning etc, but the 3-4 times this has happened it's now fixed it for me every time.

Like I say, I never looked at my logs in detail again once I knew the fix, when it happened, but it *may* be a similar issue?
 
Top