• Hey! Guest! The 36th GMC Jam will take place between February 27th, 12:00 UTC - March 2nd, 12:00 UTC. Why not join in! Click here to find out more!

windows uwp, xbox one export

hi!
i need some help to export my game for uwp / xbox one.
ich have installed visual studio community 2015 with all needed modules. windows 10 sdk is also installed. game maker studio pro has passed the check.

now if i try to compile my game for windows uwp (like to test my game on my xbox one) i get this error message after compile:

Error information: "Error: SignerSign() failed." (-2147024885/0x8007000b)
SignTool Error: An unexpected internal error has occurred.
cmd /c "Powershell -executionpolicy unrestricted "& 'C:\Users\frank\Documents\Visual Studio 2015\Projects\App1\iFTh3n_1.0.0.0\\Add-AppDevPackage.ps1'" "

maybe someone can tell me stepByStep how to setup all this?

thanks :)
 
ok...
thanks for your feedback, rIKmAN!
i have checked your tips but i´ve got the same error. my package is not digitaly signed. i don´t understand, what this mean... :/
 

rIKmAN

Member
ok...
thanks for your feedback, rIKmAN!
i have checked your tips but i´ve got the same error. my package is not digitaly signed. i don´t understand, what this mean... :/
Did you set everything up as per the guide I linked on the YYG blog post?

I have not tried exporting via UWP yet so I can't speak from experience, but I might give it a go in the next couple of weeks by enabling dev mode on my XB1.

If you followed the blog guide and it's still not working, maybe have a check of the File->Preferences and Global Game Settings to see if there are any options in the UWP tabs which might help?

Sorry I can't help you more, but please update this post with any more information / solutions you find.
 
yes. i have followed the guides. everything is work fine with visual studio. also the compiler works with my game but in the end it says that my paxkage is not digitaly signed. maybe its because uwp on game maker studio is still beta? not fully supported? maybe we have to register at yoyogames to export and run uwp?

if i have any news i will tell you :)

greets!
frank
 

rIKmAN

Member
yes. i have followed the guides. everything is work fine with visual studio. also the compiler works with my game but in the end it says that my paxkage is not digitaly signed. maybe its because uwp on game maker studio is still beta? not fully supported? maybe we have to register at yoyogames to export and run uwp?

if i have any news i will tell you :)

greets!
frank
In the post I linked to @rwkay said that it works, so I doubt that it's because it's beta otherwise I assume he wouldn't have posted instructions and said that it works.

In Global Game Settings > Windows UWP > Installation there is a box that asks for "Certificate (UWP)", have you set this?
It sounds like it could be relevant.

There is a link here on MSDN on creating your certificate / .pfx file - and it's a .pfx file that GM is asking for in the Global Game Settings section I mentioned above.

All the info is in that MSDN link on how to do it, but the part that sounds like this might be your problem is:
Then you can use the certificates to sign the app packages, so they can be deployed locally for testing.
Let me know how it goes.
 
hi!
yes, i have installed the asked certificate in game maker studio with the same error message. not signed :/
i have also checked your link to msdn but i dont understand how to handle that with my certificate.

in my game maker studio projectdrawer /configs i found my certificate pfx-file and i installed it to my pc. with no positive results
 

rIKmAN

Member
hi!
yes, i have installed the asked certificate in game maker studio with the same error message. not signed :/
i have also checked your link to msdn but i dont understand how to handle that with my certificate.

in my game maker studio projectdrawer /configs i found my certificate pfx-file and i installed it to my pc. with no positive results
Did you manage to get this working?
 
no. not yet.
maybe because of windows 10 insider preview build on my pc. i have installed now windows 10 home. i have to reinstall VS2015 and try again to export my game as uwp

did you? :)
 

rIKmAN

Member
no. not yet.
maybe because of windows 10 insider preview build on my pc. i have installed now windows 10 home. i have to reinstall VS2015 and try again to export my game as uwp

did you? :)
Not tried yet, kind of waiting to see how you get on as I want to test XB1 and it involves moving a few hundred gigabytes of games from my internal drive so I can switch the console into developer mode.

If you can't get it working just on Windows, I doubt XB1 will work either.
 
hi there!
ok. uwp export is now working.
my steps so far:
download the latest early access game maker studio!
switching the language on my system from german to english. (i read some about that...)
used the pfx key from game maker studio, as publisher name i choose Sandobox.

some guys tells the forum that you only able to export to uwp if your win10 system run with english language. but i changed my language setting back again to german and it works also. maybe the problem was not the correct version of the early access game maker...

you can found him here:
http://store.yoyogames.com/downloads/gm-studio-ea/release-notes-studio.html


xbox one support is not avaible for now. yoyogame told my that he talking about that. hmm... but how sell some guys game maker studio games on xbox store? maybe a beta thing? i think so...


greets from germany!
have a nice time!
 

rIKmAN

Member
hi there!
ok. uwp export is now working.
my steps so far:
download the latest early access game maker studio!
switching the language on my system from german to english. (i read some about that...)
used the pfx key from game maker studio, as publisher name i choose Sandobox.

some guys tells the forum that you only able to export to uwp if your win10 system run with english language. but i changed my language setting back again to german and it works also. maybe the problem was not the correct version of the early access game maker...

you can found him here:
http://store.yoyogames.com/downloads/gm-studio-ea/release-notes-studio.html


xbox one support is not avaible for now. yoyogame told my that he talking about that. hmm... but how sell some guys game maker studio games on xbox store? maybe a beta thing? i think so...


greets from germany!
have a nice time!
That's great news, congratulations! :)
I have a feeling that maybe it being a Preview build of Windows 10 may have been the issue, or maybe an update in the new EA of GMS, but either way I am glad it's working for you now.

Did you use the pfx certificate generated by GMS or did you create your own using the instructions from the link I posted earlier in the thread?

As for XB1, it is not "officially" supported and so no instructions will be given from the Helpdesk on the steps needed to get it working (I've tried), but Russell (YYG Staff) has posted on the thread saying that UWP does in fact work on XB1 but there are a lot of hoops to jump through.

He gave some steps to get it working, but nothing detailed so I am guessing I will need to do a bit of trial and error - which i will be happy to do now you have confirmed you have it working to Desktop, but maybe til not after Xmas now as it's a busy time for me.

The post from Russel with the pseudo instructions can be found here
 
Last edited:

rIKmAN

Member
thanks for infos, rIKmAN

i will try out it later after i created my dev account. i think you need that to start your xb1 in dev mode.


have a nice time!
frank
Yeah you do - it wipes the internal drive and I have a few hundred gigs of games on it that I need to copy to my external so I don't have to re-download them.

You also need the Developer Mode Activation App - info can be found here: http://support.xbox.com/en-GB/xbox-one/apps/developer-mode-activation-app-faq

Let me know how you get on!
 
hi there :)

its a long way to the top if you wanna... xbox one :D
i made it! my game is runing now on xb1 \o/

its was not really hard to do this. export to uwp in gm:s, created devAccount @ micro$oft, installed the devApp on xb1, installing my game with my browser on the xb1, switched my xb1 to the devMode, run my game...

i can link you a video of the first run on xb1

have a nice time there!
 

rIKmAN

Member
hi there :)

its a long way to the top if you wanna... xbox one :D
i made it! my game is runing now on xb1 \o/

its was not really hard to do this. export to uwp in gm:s, created devAccount @ micro$oft, installed the devApp on xb1, installing my game with my browser on the xb1, switched my xb1 to the devMode, run my game...

i can link you a video of the first run on xb1

have a nice time there!
Awesome, would love to see a video of it running on the XB1, and anything you had trouble with along the way, tips, tricks etc?

Congrats! :)
 
hi there!

well.. no trouble! it was very easy to upload my game to my xb1.

here my video:


the black border around my game... well :D i was thinking about a lot after install the game on xb1. should i do this? should i do that? whats wrong with my code? bla bla bla...

and in the end it was a settingThing on xb1. (apps can have border [yes] [no]) :D

if you have any question: let me know!


greets!
frank


(my game is still in alpha!)
 

rIKmAN

Member
@herrMartinelli That looks awesome - so cool to see it running on a console. :D

The water looks great, the player ship seems really responsive, looks like you have a good foundation of a game there!

Thanks for doing the video I appreciate it, and the tip about the border will surely help me in future when it inevitably happens to me too haha!

If you need any other XB1 testers in future let me know - I'd be happy to help.
It's always good to have someone else on the same path to bounce ideas off and discuss problems with - there doesn't seem to be too many people targeting XB1 right now so I'm always open for a message if you need a sounding board or to discuss ideas/problems etc! :)

Good luck, and thanks again! :)
 
S

Samx89

Guest
I got same problem, after updating my GMS to v1.4.1767, Error information: "Error: SignerSign() failed." (-2147024885/0x8007000b)
SignTool Error: An unexpected internal error has occurred. I don't know how to fix it.
 
Top