• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Windows 10 Update has broken application_surface resizing?

Snowcart

Member
So I am using some very simple code to set the application_surface to be the same size as my window.

GML:
if (window_get_fullscreen())
{
    if (surface_get_width(application_surface) != display_get_width())
    {
        surface_resize(application_surface, display_get_width(), display_get_height());
    }
}
else
{
    if (surface_get_width(application_surface) != window_get_width())
    {
        surface_resize(application_surface, window_get_width(), window_get_height());
    }
}
Was working yesterday. Last night I left windows on to update. (I am on the Windows Preview build, for other development work purposes)
Today I am now getting this error anytime surface_resize is called I have only tested this with the application_surface.
1586739503080.png
"
Win32 function failed: HRESULT: 0x887a0001
Call: at line 373 in file \Graphics_DisplayM.cpp
"

I am wondering if anyone else is now having this issue, and if there is anything I can do to fix it?

Do we need to wait for YoYo to fix this issue once the Windows update is actually out?
 
I'm not having this issue at the moment, but I have seen similar errors happen before when trying to resize a surface when the parameters are equal to 0.

If you haven't already, check the values that window_get_width()/height() and display_get_width()/height() are returning(before you call surface_resize(). If they are returning 0 at any point, then don't do the surface resize operation. Just a guess, maybe some change has happened where at the start of the game the window size is returning 0 for a frame or two.

If they are returning correct values, or returning 0 continuously, then sounds like a bug in that case.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
You say your using the preview build and that this was working yesterday... you can't expect YYG to jump on every issue that appears in an untested new build that isn't actually in stable yet... apart from that,
have you rebooted, and then checked for a new driver and/or a know issue with the fast ring update you just installed? The issue sounds more like a problem with the update and the GPU drivers than something YYG should jump on to fix just now.
 

O.Stogden

Member
As it's a preview build of Windows, it's more likely that this is an issue with Microsoft rather than GMS.

Preview builds are unstable and meant for testing, they're not suitable for a PC you're developing on, as it could cause a crash.
 

Snowcart

Member
As it's a preview build of Windows, it's more likely that this is an issue with Microsoft rather than GMS.

Preview builds are unstable and meant for testing, they're not suitable for a PC you're developing on, as it could cause a crash.
Yes, the point of me running it is to fix some of our legacy software preemptively so that by the time a windows release does happen bugs are ironed out.
 

ph101

Member
I hope this doesn't mean that an incoming windows 10 update will (from the look of it) break either window_get_width() or display_get_width() causing them to return 0.
Have you confirmed that (I agree if they were returning 0 that would cause the error - so debug what values they return).
Also though in general it doesn't seem likely YYG can really address this until the ms patch is live. I just personally hope that it doesn't break that function as obviously they are quite an improtant one(s). That all said If you confirmed that happens, or if its surface resize that is the issue, imo its still worth submitting the issue to YYG as a head up that something serious could be on the way.
 

curato

Member
I have seen some issues like that where you have more that one app open trying to use the resource. A reboot usually takes care of it. I can't use splash top on win10 while gamemaker is open or I get a similar error when I try to run a game in debug mode.
 
Top