Windows Windows 10 "Synchronization To Avoid Tearing" option capping game at 30FPS

R

Ryeman95

Guest
I am using GM:S 1.4.1773 and have recently upgraded to Windows 10 on a new desktop PC. I have been running my game maker project (a retro style RPG game) on my windows 7 PC comfortably at 60FPS with the "Use Synchronization To Avoid Tearing" option enabled to smooth the appearance of the game.

The room is always set to a speed of 60 and has always run just fine. On my new computer then, it is then extremely perplexing when selecting 'RUN' to see the FPS GUI at the top of my screen performing what appears to be an artificial capping on the frame rate to between 29-30fps, slowing everything down.

I have tried 'Alternate Synchronization Method' as well as selecting software vertex processing with either option with very little idea as to what's going wrong.

Absolutely stumped.

Anyone else found this issue?
 
Top