• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Question - IDE Will "alternate synchronization method" come to GMS2?

meltypixel

Member
I recently upgraded my project to GMS2. I've had issues with the default synchronization method in 1.4, but I found success using the "alternate synchronization method" previously available in the advanced Windows graphics settings. It seems this is no longer an option in GMS2.

Is the "alternate synchronization method" option coming back, or am I missing it somewhere?


The reason I have issues with the default sync is this: My room speed is set to 60, but occasionally the frame rate will slow down when the game is doing a bit of heavy lifting, specifically in a certain menu where a high frame rate isn't necessary. The problem is that on slower computers, if the frame rate goes below 30, the vsync will lock to 30fps and the game physics will slow down, so everything moves as if in slow motion. Even if fps_real comes back up, the game will not sync to 60fps again.

Thank you for your help.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
That functionality will not return because it was a function of DX9 and GMS2 uses DX11 which doesn't have it.
 

meltypixel

Member
That functionality will not return because it was a function of DX9 and GMS2 uses DX11 which doesn't have it.
Ah, that's too bad. Well, if anyone's got any idea what's causing my frame rate to lock to 30 instead of 60 and my physics to slow down, I'd appreciate it. Otherwise, I guess I'm rolling back to 1.4.
 

Mick

Member
Ah, that's too bad. Well, if anyone's got any idea what's causing my frame rate to lock to 30 instead of 60 and my physics to slow down, I'd appreciate it. Otherwise, I guess I'm rolling back to 1.4
You should use the profiler in the debugger to figure out what is causing your game to slow down. I haven't used the profiler in GMS2 so I can't give any more guidance about it.
 

meltypixel

Member
I appreciate the suggestion, Mick. I'm no stranger to the profiler, though.

To be clear, my problem is not what's causing my game to slow down, because I know what's doing it. The problem is that when that thing goes away and the real fps goes back up, the default synchronization locks the game to 30fps and puts the physics into slow motion. This does not happen with alternative sync in GMS 1.4, and it doesn't happen when sync is turned off.
 
Please file a bug. :)
You guys should prepare a "please file a bug" form response that includes a link to the bug tracker/an explanation of what to include or whatever.

Just a suggestion, since I see you guys asking pepole to file bugs fairly often, and I always wonder what percentage of people actually take the time to do it, hahah. ^ ^"
 

Lukan

Gay Wizard Freak
Check your game's FPS setting. This gets set to a default of 30 even when importing projects.
 

meltypixel

Member
Thanks, Nocturne! I appreciate your help a lot. I'll try to whip up an example project that demonstrates the problem in an easily reproducible way in case that helps.

Lukan, I know how to set the framerate. Thanks for your input, though. ;)

That should be a wrap on this thread, I think.
 

meltypixel

Member
Just a quick update in case someone with a similar problem ever googles this and is like "BUT WHAT HAPPENED?"

After trying to recreate the issue in a new project, it's looking like the issue isn't necessarily what I thought. Something sneaky is going down in my project, and I think GMS is not to blame.

If I figure it out, I'll come back and update. Thanks for putting up with me, everybody!
 
Top