GMS 2.3+ Weird Object glitch

ww_y

Member
I'm having this weird situation where anytime I put a new object in the room, even if it has no code, it turns into a copy of the player object. I've tried adding code to the new object, making the new object a child of a parent with a different code than the player, I have even tried putting code in the new object to cause a Game Maker error and nothing. It all just gets ignored and turns the new object into a copy of the player object, code, and all. And this persists room to room. I just end up with a bunch of player objects responding to control inputs all at once. Has anyone else experienced this? Maybe there's a box I checked that causes this to happen? I have examined every script and every other object around and dont see any code that would turn a newly made object into the player object or even any reference to the player object.
 

TsukaYuriko

☄️
Forum Staff
Moderator
Restructure the game so it's themed around the player cloning themselves... :)

On a more serious note, try clearing the asset cache (Ctrl+F7).

If that doesn't help, does this also occur in an otherwise empty room? If not, make a backup and remove instances one by one until the problem disappears to find out what's causing it.
 
Top