3D Water flicker

Misty

Member
Ok so i have giant world terrain that is supposed to be the size of California...takes 1 minute to load because i have to smooth all the normals...

Then I have the flicker...the water flickers on it
No way to get rid of it not even d3d_setzwriterenable

Ready to call it quits and just do some weird polygonal terrain...
 

Roa

Member
Define a custom view frustum using d3d_set_projection_ext and make the close and far clipping planes bigger.
 

Misty

Member
I did but I have to make the close plane so big that it clips through everything. Theres got to be a better way to do this.
 

Roa

Member
what number did you throw in there? It should be smaller than what ever the collision box for the camera is.
 

FredFredrickson

Member
GMC Elder
You could try drawing things at a different scale, or splitting up the water into a grid of planes/triangles so you're not drawing such a large piece at once.
 

Roa

Member
You could try drawing things at a different scale, or splitting up the water into a grid of planes/triangles so you're not drawing such a large piece at once.
Nah, he is talking about z fighting. The problem is the ratio of clipping planes to how close in decimal the polygons are.

@Misty Use a clipping pair of 4 and 2048 and see what happens.
 
Last edited:

FredFredrickson

Member
GMC Elder
Nah, he is talking about z fighting. The problem is the ration of clipping planes to how close in decimal the polygons are.
I understand what the problem is, but I've found that sometimes if I change the scale of things, it can give me more room to work in. Similarly, I've also seen games have z accuracy problems with super large planes, and I've found that splitting them can help.
 

Misty

Member
Oddly enough, setting the view to 8 and and 4096*8 was all it took to stop the zfighting.
 
Top