• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android / Amazon Fire WARNING: Configuration 'compile' is obsolete

N-Code

Member
Hi all, hoping someone can help me with understanding this error:

> Configure project :allib
WARNING: Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html
> Configure project :com.MCP.Eagles_Bears_n_Fish
WARNING: Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html
FAILURE: Build failed with an exception.
* Where:
Build file 'W:\com.MCP.Eagles_Bears_n_Fish\build.gradle' line: 57
* What went wrong:
A problem occurred evaluating project ':com.MCP.Eagles_Bears_n_Fish'.
> Project with path ':library' could not be found in project ':com.MCP.Eagles_Bears_n_Fish'.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
 
Top