• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Discussion VS2015 Theme - Flat Visual Studio skin for GMS2 (Light/Dark) - Updated August 25 for GMS2.1

3

39digits

Guest
does anyone know how to change the color for rooms which are inherited. This room has a parent room so all the layers get highlighted in this color which makes it hard to read. I just wanna know how/where I need to go to edit this.

The same happened to me on a project I'm working on atm when using VS Dark Blue. I created a Child of a Room and the interface showed the inherited layers in the same way as your screenshot.

I tested this with the default Dark theme and it does the same (although in the default theme the light icons are more noticeable at least).

I found restarting the IDE cleared that completely and it used the expected darker settings (in either default Dark or the VS Dark Blue themes). So I think this might be a bug in the IDE itself.

I tried tinkering with the theme files in `Styles/styles_roomeditor.json` but couldn't find a solution - did you ever figure it out?
 
You can right-click on the app and select "Open Package Contents" then browse to Contents/MonoBundle/GUI/Skins and put the folder in there. I'm not sure yet what impact that would have when GameMaker gets its next update though.

Edit: But putting the skins in /Users/Shared/GameMakerStudio2/Skins worked for me.
Huh, that's really weird, it does not work for me trying to do that. I even reinstalled game maker to try to get it to work, but unfortunately it did not work, I will try to put it in the package content to try it out
 

erryox

Member
The same happened to me on a project I'm working on atm when using VS Dark Blue. I created a Child of a Room and the interface showed the inherited layers in the same way as your screenshot.

I tested this with the default Dark theme and it does the same (although in the default theme the light icons are more noticeable at least).

I found restarting the IDE cleared that completely and it used the expected darker settings (in either default Dark or the VS Dark Blue themes). So I think this might be a bug in the IDE itself.

I tried tinkering with the theme files in `Styles/styles_roomeditor.json` but couldn't find a solution - did you ever figure it out?
Put the fixed files here "*/VS Dark Blue/Styles/".
https://www.dropbox.com/s/4ia0mtm9w4zgqc6/styles_roomeditor.json?dl=0
https://www.dropbox.com/s/mhu13tffn9yymo5/styles_workspaceoverview.json?dl=0
 

Sammi3

Member
How do I change the size of the event thumbnails (i.e Create, etc) Currently they're too small for my liking

EDIT: And the padding between events
 

Lonewolff

Member
Man, that's heaps better!

I don't feel like I am having an aneurysm anymore when I run GMS side by side with Visual Studio, with the light vs dark theme clash.


[edit]
Although having said that, I just changed my theme back to the normal one and GMS 2 doesn't open anymore. Yay! o_O


[edit 2]
Deleting the new them entirely fixed it. Think I'll stick with the aneurysm.
 
Last edited by a moderator:

DOTEW

Member
I keep getting "There was and error downloading your file"
please upload another link or upload to mediafire or something

thank you!
 

davawen

Member
The Skin doesn't seem to work for me in the latest version, Even though it's selectioned, the color schemes or icons doesn't change, for the dark blue version anyway...
Mick dark green version fix this, so is it just because the old theme has become incompatible ? That would really suck...

EDIT : Nevermind, I putted it in Program Files\GameMaker Studio 2 instead of YoYoGames\GMS 2.0\GameMaker Studio 2
 
Last edited:
Top