• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Very Long Time to Run(F5) Project

I had just recently bought GMS2 with the developer license and installed it on my desktop PC. An odd issue I have been having that I haven't been finding any solutions for is that when I run a project that I am creating, it takes a very long time to load.

A blank room with one object takes nearly 40 seconds just to run, while in videos I have seen people load their large projects in seconds.

When running a project my computer doesn't slow down and the RAM and CPU usage are relatively small.
I would like to think my computer specs aren't too bad with
16gb ram
4.0GHz CPU
radeon r9 380x 4gb GPU

I am hoping to find a fix or a way to make my project load much faster, as it is quite ineffective.
Thankyou if you can help!
 
Here is the console output when I run a project:
=================================================================================================
"cmd" /c subst Z: "C:\Users\######Gaming PC\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE"

elapsed time 00:00:00.0480003s for command "cmd" /c subst Z: "C:\Users\######Gaming PC\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE" started at 10/26/2018 21:36:27
"cmd" /c subst Y: "C:\Users\###### Gaming PC\AppData\Local\GameMakerStudio2\GMS2TEMP"

elapsed time 00:00:00.0989980s for command "cmd" /c subst Y: "C:\Users\######Gaming PC\AppData\Local\GameMakerStudio2\GMS2TEMP" started at 10/26/2018 21:36:27
"cmd" /c subst X: "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.2.0.258"

elapsed time 00:00:00.0529988s for command "cmd" /c subst X: "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.2.0.258" started at 10/26/2018 21:36:27
Saving project to: D:\Game Maker\Projects\My First Game\My First Game.yyp
"C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.2.0.258/bin/Igor.exe" -options="C:\Users\######Gaming PC\AppData\Local\GameMakerStudio2\GMS2TEMP\build.bff" -- Windows Run

Loaded Macros from C:\Users\######Gaming PC\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE\My_First_G_989A7EE4_7C8C4BB0\macros.json
Options: X:/bin\platform_setting_defaults.json
Options: C:\Users\######Gaming PC\AppData\Roaming/GameMakerStudio2\mlorenz1012_1788002\local_settings.json
Options: C:\Users\######Gaming PC\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE\My_First_G_989A7EE4_7C8C4BB0\targetoptions.json
X://bin/GMAssetCompiler.exe /c /zpex /mv=1 /iv=0 /rv=0 /bv=0 /j=8 /gn="My First Game" /td="Y:/" /cd="Z:/My_First_G_989A7EE4_7C8C4BB0" /zpuf="C:\Users\######Gaming PC\AppData\Roaming/GameMakerStudio2\mlorenz1012_1788002" /m=windows /tgt=64 /nodnd /cfg="default" /o="Y:/My_First_Game_1C7140F9_VM" /sh=True /optionsini="Y:/My_First_Game_1C7140F9_VM\options.ini" /cvm /baseproject="X:/BaseProject\BaseProject.yyp" "D:\Game Maker\Projects\My First Game\My First Game.yyp" /preprocess="Z:/My_First_G_989A7EE4_7C8C4BB0"
Reading project file....D:\Game Maker\Projects\My First Game
Reading project file....X:\BaseProject
Reading config delta 'D:\Game Maker\Projects\My First Game\options\main\inherited\options_main.inherited.yy'
finished.


X://bin/GMAssetCompiler.exe DONE (0)
Release build
OptionsIni
Options: Z:/My_First_G_989A7EE4_7C8C4BB0\PlatformOptions.json
[Compile] Run asset compiler
C:\WINDOWS\system32\cmd.exe /c ""X://bin/GMAssetCompiler.exe" /c /zpex /mv=1 /iv=0 /rv=0 /bv=0 /j=8 /gn="My First Game" /td="Y:/" /cd="Z:/My_First_G_989A7EE4_7C8C4BB0" /zpuf="C:\Users\######Gaming PC\AppData\Roaming/GameMakerStudio2\mlorenz1012_1788002" /m=windows /tgt=64 /nodnd /cfg="default" /o="Y:/My_First_Game_1C7140F9_VM" /sh=True /optionsini="Y:/My_First_Game_1C7140F9_VM\options.ini" /cvm /baseproject="X:/BaseProject\BaseProject.yyp" "D:\Game Maker\Projects\My First Game\My First Game.yyp" /bt=run"
Reading project file....D:\Game Maker\Projects\My First Game
Reading project file....X:\BaseProject
Reading config delta 'D:\Game Maker\Projects\My First Game\options\main\inherited\options_main.inherited.yy'
finished.
Compile Constants...finished.
Remove DnD...finished.
Compile Scripts...finished.
Compile Objects...finished.
Compile Timelines...finished.
Compile Triggers...finished.
Compile Rooms...finished.
Compile Extensions...finished.
Global scripts...finished.
Final Compile...finished.
Saving IFF file... Y:/My_First_Game_1C7140F9_VM\My First Game.win
Writing Chunk... GEN8
option_game_speed=30
Writing Chunk... OPTN
Writing Chunk... LANG
Writing Chunk... EXTN
Writing Chunk... SOND
Writing Chunk... AGRP
Writing Chunk... SPRT
Writing Chunk... BGND
Writing Chunk... PATH
Writing Chunk... SCPT
Writing Chunk... GLOB
Writing Chunk... SHDR
Writing Chunk... FONT
Writing Chunk... TMLN
Writing Chunk... OBJT
Writing Chunk... ROOM
Writing Chunk... DAFL
Writing Chunk... EMBI
Writing Chunk... TPAGE
Texture Group - Default
Writing Chunk... CODE
Writing Chunk... VARI
Writing Chunk... FUNC
Writing Chunk... STRG
Writing Chunk... TXTR
0 Compressing texture... writing texture texture_0.png...
Writing Chunk... AUDO
Writing Chunk... SCPT
Writing Chunk... DBGI
Writing Chunk... INST
Writing Chunk... LOCL
Writing Chunk... STRG
Stats : GMA : Elapsed=664.013
Stats : GMA : sp=2,au=0,bk=0,pt=0,sc=0,sh=0,fo=0,tl=0,ob=2,ro=1,da=0,ex=0,ma=3,fm=0x200400200020


C:\WINDOWS\system32\cmd.exe DONE (0)
DoSteam
Igor complete.
[Run] Run game
Options: Z:/My_First_G_989A7EE4_7C8C4BB0\MainOptions.json
X://windows/Runner.exe -game "Y:/My_First_Game_1C7140F9_VM\My First Game.win"
Attempting to set gamepadcount to 12
DirectX11: Using hardware device
Total memory used = 7591572(0x0073d694) bytes
===========================================================================


hopefully that can be used
 
Last edited:

Joe Ellis

Member
Your computer is faster than mine, and my projects usually load in about 3 - 10 seconds, sorry I havent got any advice, how long have you had your computer? It could have a virus,
 
Your computer is faster than mine, and my projects usually load in about 3 - 10 seconds, sorry I havent got any advice, how long have you had your computer? It could have a virus,
hmm thanks for the quick response, I've had my computer for 1-2 years, currently I don't have any similar issues with any other programs. Photoshop loads up quickly and many games as well.
 

sylvain_l

Member
what is your second hard drive? if it's not a SSD that could explain the delay (mostly if it's a 5400rpm very fragemented HDD)
 
I've solved my problem! :) , all I did was reinstall GMS onto my other hardrive, and now my project loading times are less than 10 seconds.
It is still strange because my HDDs are nearly identical, my second drive was a 1tb 7400 rpm Seagate BarraCuda, nonetheless my issue is resolved.
Thank you

EDIT: My issue has not been resolved and it still persists, RIP. I thought it worked earlier.
 
Last edited:

nlolotte

Member
what is your second hard drive? if it's not a SSD that could explain the delay (mostly if it's a 5400rpm very fragemented HDD)
I think this could be the issue.

I am using an I5 7400k @3.5ghz, 16gb RAM and a 6gb GTX 1060. My primary drive with my windows installation on is a 200gb SSD and my slave drive is a 1tb HDD.

I suffer from terrible compile times, sometimes minutes. My GMS2 install is on the HDD and it makes no difference. How big is your project?
 
Last edited:
I've tried reinstalling Gamemaker on both my drive, one is 7400rpm 1tb SSHD and the other is 7400rpm 1tb HDD, no luck although when i first installed it to the SSHD it ran quickly at first.
This happens when i run a with a project with no objects, no sprites, and just one room.

I have also noticed in the output console when I run it will almost instantly reach the lines saying

C:\WINDOWS\system32\cmd.exe DONE (0)
DoSteam
Igor complete.
[Run] Run game
Options: Z:/testing_5E946A71\MainOptions.json
X://windows/Runner.exe -game "Y:/testing_56342276_VM\testing.win"

however it stops at that point and takes nearly 30 seconds before it proceeds to say

Attempting to set gamepadcount to 12
DirectX11: Using hardware device
Total memory used = 6510379(0x0063572b) bytes
and then my project will finally open.
After that the rest of the console output will say

Resizing swap chain...Attempting to set gamepadcount to 0
---------------------------------------------------------------
minFPS, maxFPS, avgFPS
318, 3048, 1853
---------------------------------------------------------------
---------------------------------------------------------------
minFPS, maxFPS, avgFPS
318, 3048, 1853
---------------------------------------------------------------


X://windows/Runner.exe DONE (0)
Igor complete.
elapsed time 00:02:21.9625330s for command "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.2.0.261/bin/Igor.exe" -options="C:\Users\Michael's Gaming PC\AppData\Local\GameMakerStudio2\GMS2TEMP\build.bff" -- Windows Run started at 10/28/2018 12:08:19
"cmd" /c subst Z: /d

elapsed time 00:00:00.0969983s for command "cmd" /c subst Z: /d started at 10/28/2018 12:10:41
"cmd" /c subst Y: /d

elapsed time 00:00:00.1119981s for command "cmd" /c subst Y: /d started at 10/28/2018 12:10:41
"cmd" /c subst X: /d

elapsed time 00:00:00.0779988s for command "cmd" /c subst X: /d started at 10/28/2018 12:10:41
SUCCESS: Run Program Complete

I am really not sure what most of this means so the info wouldn't be useful to myself.
 

sylvain_l

Member
just an idea: perhaps your antivirus catch the exe when it's launch and analyse it before allowing it to run. (and in case you have assets - music and sprite - of course that make a lot more of data to parse) why the 30sec delay
 
After doing a little bit of experimenting I figured a little bit out.

When I restart my PC gamemaker will run my projects fine and open instantly the first several times I run my project, but then after a few times, it suddenly takes 30+ seconds to run the project. It won't open instantly until I restart the PC again. This means my PC is capable of opening the projects quickly, but i am not sure why it only works a few times and then stops.
I have tried clearing temp directory, asset cache, and IDE cache but it did nothing.
I turned off my antivirus and that didn't do anything.
Next I will try to do a thorough virus scan on my PC.

(The manual AND the marketplace were showing up as white screens with a loading symbol today but then it fixed itself..?)
I really hope I can fix this soon.
 

nlolotte

Member
I get the same thing, a restart fixes it for the first 5 or so runs. Have you noticed something like this:
T://windows/Runner.exe -game "U:....
The strange thing is, I dont have a T drive :S

EDIT: apparently I do now, infact I have aquired several whilst running my game

 

Dog Slobber

Member
When you compile and run games Studio (Windows only) creates temporary virtual drives. It starts at the last available drive, usually z: and works backwards.

Note how drives T: U: V: W: X: and Z: all have the same free space and size as C:.
 
When you compile and run games Studio (Windows only) creates temporary virtual drives. It starts at the last available drive, usually z: and works backwards.

Note how drives T: U: V: W: X: and Z: all have the same free space and size as C:.
do you suppose these temporary drives can be running incorrectly, or be creating unnecessary information slowing the game running
 

nlolotte

Member
When you compile and run games Studio (Windows only) creates temporary virtual drives. It starts at the last available drive, usually z: and works backwards.

Note how drives T: U: V: W: X: and Z: all have the same free space and size as C:.
I thought the latest release prevented so many drives being created?

  • Fixed the runtime installation process so it uses fewer temporary drive mappings, which should stop "Z:\manifest" errors.
 

Dog Slobber

Member
I thought the latest release prevented so many drives being created?

  • Fixed the runtime installation process so it uses fewer temporary drive mappings, which should stop "Z:\manifest" errors.
It has, but neither of the posters share what version they're using. Add to that, one of the problems some have posted about is the temporary virtual drives not being removed after the build process.
 
When I restart my PC and open game maker, and run my project and it loads correctly and quickly, it only creates ONE temporary drive, which disappears when I exit the game.
When my issue starts, it creates about THREE temporary drives when i made no changes and im running a project with no assets.

It says i am running IDE v2.2.0.343 and Runtime v2.2.0.261 which i would assume is the latest.
 
It has to be an issue with my PC running Gamemaker Language games. Most games work fine on my PC but recently I have tried ‘Deltarune’ which I am assuming was made in Gamemaker as was Undertale. Deltarune takes a very long time to physically launch, almost a minute, and it loads well once it launches however every several minutes it stops responding for around 30 seconds
 
M

Munk

Guest
It has to be an issue with my PC running Gamemaker Language games. Most games work fine on my PC but recently I have tried ‘Deltarune’ which I am assuming was made in Gamemaker as was Undertale. Deltarune takes a very long time to physically launch, almost a minute, and it loads well once it launches however every several minutes it stops responding for around 30 seconds
There has to be something about this. Compiling to test little things and waiting 10 seconds when in GMS1 it was instant has been driving me crazy. Then you got me thinking, and yeah Deltarune takes the same amount of time to launch as running my project in GMS2. There's gotta be something I can do to make this run faster.
 

EvanSki

Raccoon Jam Host
I get the same thing, a restart fixes it for the first 5 or so runs. Have you noticed something like this:


The strange thing is, I dont have a T drive :S

EDIT: apparently I do now, infact I have aquired several whilst running my game

Ive noted GMS2 likes to make vertural Storage to run the game, Causing Extreme memory leaks and LAG
 
Last edited:
P

ponotte

Guest
I had just recently bought GMS2 with the developer license and installed it on my desktop PC. An odd issue I have been having that I haven't been finding any solutions for is that when I run a project that I am creating, it takes a very long time to load.

A blank room with one object takes nearly 40 seconds just to run, while in videos I have seen people load their large projects in seconds.

When running a project my computer doesn't slow down and the RAM and CPU usage are relatively small.
I would like to think my computer specs aren't too bad with
16gb ram
4.0GHz CPU
radeon r9 380x 4gb GPU

I am hoping to find a fix or a way to make my project load much faster, as it is quite ineffective.
Thankyou if you can help!
have you found an solution? i have the exacly same problem. and here's my thread about it.
https://forum.yoyogames.com/index.php?threads/gms-2-compile-time-way-too-long.56364/
 

Gunner

Member
What is your CPU exactly OP? "4.0 GHz" isn't something useful as an information.. That's just a clock speed, you could have some crappy AMD proc from last decade and clock it at that speed, and perform worse than current gen low powered proc @0.9 GHz..

Let us know your actual CPU, like i7 6700K or something.

Also, in case you're using a laptop, make sure you don't set it at power saving mode as it can hold your CPU performance hence making the compile time longer.

In most cases this should be your CPU though.

Just as a comparison, I'm running a laptop with only i7 4720HQ (default clock speed), 8GB DDR3, 120GB cheap SSD, and my project (around 50-100MB project) compiles under 10 sec, at most 13-15. Power management set to balanced. If I set it to power saver, it will compile well over a minute.

While at it, if all else fails, I highly recommend @YellowAfterlife 's extension called GMLive. Costs $30, but will make you wonder how in the world is it not included inside GameMaker itself. While running the game, just edit the source code, save the project, then your game is updated without having to need to recompile/rerun!
 
Last edited:
P

ponotte

Guest
What is your CPU exactly OP? "4.0 GHz" isn't something useful as an information.. That's just a clock speed, you could have some crappy AMD proc from last decade and clock it at that speed, and perform worse than current gen low powered proc @0.9 GHz..

Let us know your actual CPU, like i7 6700K or something.

Also, in case you're using a laptop, make sure you don't set it at power saving mode as it can hold your CPU performance hence making the compile time longer.

In most cases this should be your CPU though.

Just as a comparison, I'm running a laptop with only i7 4720HQ (default clock speed), 8GB DDR3, 120GB cheap SSD, and my project (around 50-100MB project) compiles under 10 sec, at most 13-15. Power management set to balanced. If I set it to power saver, it will compile well over a minute.

While at it, if all else fails, I highly recommend @YellowAfterlife 's extension called GMLive. Costs $30, but will make you wonder how in the world is it not included inside GameMaker itself. While running the game, just edit the source code, save the project, then your game is updated without having to need to recompile/rerun!
it has nothing to do with specs, i've had this problem for a long time, im running i5-3570k 4.3ghz, 16gb ram, ssd, 970gtx. and the projects used to compile normally in 2-5sec, but when this problem appear, compile time goes up to minute and wont go away until pc restart, just like the op said. this is the only thread i've found from the whole internet that has the same problem that i do. i even reinstalled my windows for this without any change, wich makes me think that it has something to do with my gamemaker license or something. i've sent ticket to support, they didn't respond, now i've sent another one, we'll see does yoyo give a damn about their customers, i hope i didn't pay 300€ for broken engine.
 
L

Lord Sampigans

Guest
I just purchased and installed Game Maker today. I have 2 drives. One is a SSD and the other is a HDD. I have the exact same issue with three drives being created when attempting to run my game. Does anybody have a fix? Reinstalling Windows is somewhat obviously not an appropriate solution.
 
D

DoktorBartas_PL

Guest
Hi,

stumbled upon the same issue today.
I've downloaded GMS2 trial version yesterday, went through Space Rocks tutorial, made a bit of some platform project. Everything was running fine; projects ran instantaneously (especially being so small, taking around 12 megs of RAM). Today, even on an empty project with a fresh PC restart, it takes more than 20 seconds to run a project. Two virtual drivers are created (didn't pay attention to this yesterday - as obviously I didn't have any issues). Same delay happens with AV off.
Bit of my output (empty project):

Code:
DoSteam
Igor complete.
[Run] Run game
Options: Z:/Test_957C0F66\MainOptions.json <------ HERE, takes a long time to go past this step
Attempting to set gamepadcount to 12
DirectX11: Using hardware device
Collision Event time(microsecs)=0
Total memory used = 5424345(0x0052c4d9) bytes
**********************************.
Entering main loop.
**********************************.
Pause event has been registered for this frame
Pause event has been unregistered
Pause event has been registered for this frame
Pause event has been unregistered
Obviously nothing changed on my PC, hardware- and software-wise since yesterday, and I'm running the newest GMS2 version available.

EDIT:

Ok, it has to do something with the additional HID devices in Control Panel, checking solution from topic "Output delay AFTER 'Options: [Path]\MainOptions.json and BEFORE Attempt to set gamepadcount [SOLVED]".

EDIT2:

Very strange. Turned off multiple HIDs, projects ran normally. Turned every HID back on, projects still run normally. For now it's solved, it may be some conflicts with iCUE software from Corsair.
 
Last edited by a moderator:

rIKmAN

Member
I just purchased and installed Game Maker today. I have 2 drives. One is a SSD and the other is a HDD. I have the exact same issue with three drives being created when attempting to run my game. Does anybody have a fix? Reinstalling Windows is somewhat obviously not an appropriate solution.
You can turn off the creation of the extra virtual drives in preferences in the latest beta.

You can either wait for it to become stable, or if you aren’t already opted in for beta versions, follow the guide found here:
https://help.yoyogames.com/hc/en-us...ting-Into-The-GameMaker-Studio-2-Beta-Channel
 
I don't think he can do that (opt into beta), since he said he's using trial version.

Edit:
Scratched the above. I just saw this post below (made 15 min) before I made this edit;
We've opened our Beta channel to free trial users.
 
Last edited:

rIKmAN

Member
I don't think he can do that (opt into beta), since he said he's using trial version.

Edit:
Scratched the above. I just saw this post below (made 15 min) before I made this edit;
The person I quoted said they purchased it in the first 3 words of their post, but yeah trial users get beta access now too so should work either way.
 

shoebby

Member
I personally had this problem and what solved it for me (and also fixed the long loading times in Godot additionally) was updating the firmware of my keyboard from Corsair. God knows why or how this influenced these loading times but it did, and now my loading times went from ~40 seconds to sub 5. So check your hardware drivers for your mouse, keyboard, or whatever you have plugged in your USB drives and update them (regularly).
 

embersky

Member
I personally had this problem and what solved it for me (and also fixed the long loading times in Godot additionally) was updating the firmware of my keyboard from Corsair. God knows why or how this influenced these loading times but it did, and now my loading times went from ~40 seconds to sub 5. So check your hardware drivers for your mouse, keyboard, or whatever you have plugged in your USB drives and update them (regularly).
Holy cow. I unplugged and plugged back in my Corsair keyboard, and that instantly resolved the problem. So bizarre. Thanks!
 
Holy cow. I unplugged and plugged back in my Corsair keyboard, and that instantly resolved the problem. So bizarre. Thanks!
I confirm your same situation, my keyboard is a Corsair Strafe and GMS2 was taking more than 30 seconds in compile a blank project with F5 then I unpluged and plugged my keyboard and it was instantly fixed. F5 now takes 1 second.
 
This is unbelievable, I have a Corsair keyboard and I've been suffering through sluggish compile times for months (exact same issues as above, compiling is relatively fast after restart but then becomes slower with subsequent compiles). Unplugging it and plugging it back in immediately solved the issue!
 

vladdeSV

Member
I personally had this problem and what solved it for me (and also fixed the long loading times in Godot additionally) was updating the firmware of my keyboard from Corsair. God knows why or how this influenced these loading times but it did, and now my loading times went from ~40 seconds to sub 5. So check your hardware drivers for your mouse, keyboard, or whatever you have plugged in your USB drives and update them (regularly).
What in the actual h*ck. I have a Corsair K95, and this solved the issue.
 
Top