• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Question - IDE Very annoying syntax error box

G

gamible

Guest
So, I like being in kind of full screen-ish view when I'm coding. So I minimized the syntax and compiling box, and I type:
Code:
player_spd =
And I have a think about how fast the player should be.
About a second later BAM the syntax box is back up.. This happens everytime. Any fixes or options idk about yet?
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
In the preferences you can change the time it takes for the syntax checker to run. It's in FIle > Preferences > Text Editor > Syntax Checking Delay
 

DeScruff

Member
Sorry to necro but... is there any other way?
Cause I find this box very annoying as well. but that setting to change the delay time does more then just affect the box, it also affects the little red "!" orb.
- I don't really see a purpose for the automatic popping up window. The "!" orb does the same exact thing, but is less intrusive, and it isn't something I need to keep closing/getting out of the way of reading other parts of my code.

As it stands this thing is just like Clippy, and we all know how well that went over.
 

FrostyCat

Member
One way is to bind the syntax toggle to a more convenient key (default Ctrl+Alt+S) and use it to turn on the syntax check only when you're done. I have mine rebound to F3, for instance.
 

gnysek

Member
Sorry to necro but... is there any other way?
Cause I find this box very annoying as well. but that setting to change the delay time does more then just affect the box, it also affects the little red "!" orb.
- I don't really see a purpose for the automatic popping up window. The "!" orb does the same exact thing, but is less intrusive, and it isn't something I need to keep closing/getting out of the way of reading other parts of my code.

As it stands this thing is just like Clippy, and we all know how well that went over.
You can disable it in options in latest version of GMS2 (which you're probably using, as it's forcing to download).
 

DeScruff

Member
General Settings > Compiling > Automatically popup syntax errors (deselect).
That... doesn't fix this exact issue. Unless I'm on an outdated version (2.0.3.56?)
Thats setting is used during compiling. What we are talking about is the real time syntax checker.
If you were to go into the creation event and on the bottom you type your own variable like "MaxHP =" and take 3 seconds to think what the number should be you will get a popup box that says "unexpected syntax error" "unexpected unary operator ="

The popup might have originally been part of the bottom bar which I closed all the tabs of because I really don't like bottom bars that take up way too much screen space - (I know you can hide it, but... if your gonna hide and never use it... why have it to begin with?)
 

YellowAfterlife

ᴏɴʟɪɴᴇ ᴍᴜʟᴛɪᴘʟᴀʏᴇʀ
Forum Staff
Moderator
That... doesn't fix this exact issue. Unless I'm on an outdated version (2.0.3.56?)
Thats setting is used during compiling. What we are talking about is the real time syntax checker.
If you were to go into the creation event and on the bottom you type your own variable like "MaxHP =" and take 3 seconds to think what the number should be you will get a popup box that says "unexpected syntax error" "unexpected unary operator ="
Other way to deal with these is to position both syntax error and compile error windows in unused space above the top barupload_2017-1-10_13-50-2.png
 

gnysek

Member
That... doesn't fix this exact issue. Unless I'm on an outdated version (2.0.3.56?)
Thats setting is used during compiling. What we are talking about is the real time syntax checker.
If you were to go into the creation event and on the bottom you type your own variable like "MaxHP =" and take 3 seconds to think what the number should be you will get a popup box that says "unexpected syntax error" "unexpected unary operator ="

The popup might have originally been part of the bottom bar which I closed all the tabs of because I really don't like bottom bars that take up way too much screen space - (I know you can hide it, but... if your gonna hide and never use it... why have it to begin with?)
Strange, as it works for me. Maybe IDE restart is needed ?
 

gnysek

Member
Well seeing as the option was unchecked when I found it... I don't think so.
I've just double checked - for sure it's that setting. But you need to have "Syntax errors" window attached to bottom bar, together with other (output, search results etc.). Then if this panel is hidden, syntax errors won't make it popup if this setting is unchecked. Also, try checking and unchecking this option (maybe it's in indeterminate state, so it's not enabled but not disabled too?).

This was checked for code editor syntax checking, not for compiling, so that must be this setting.
 

DeScruff

Member
I am doing exactly that. - I can't record a GIF long enough to do what you did.
But go ahead and look I got the thing to popup, even though its unchecked. (even note the greyed out Apply button)

EDIT: I need it attach to the bottom eh? - Well Thats a problem, cause I don't want a bar on the botom! - the only solution is to have it attached to the side with resources. which is why I hate this thing. I don't want this syntax error checking tab at ALL. The red "!" orb is more then enough to tell me I have an error without getting all up in my face and telling me I haven't completed typing a variable.

TLDR - I don't want this tab thing at all, I like the red "!" orb though because it is not nearly as annoying, and its still helpful. - "Clippy 'syntax check' jr." is not
 

Attachments

Last edited:

gnysek

Member
Yeah, put it on bottom, and it wont popup anymore if this checkbox in options I mentioned is unchecked. Really.
 

DeScruff

Member
Put the syntax error box back in the dock at the bottom.
Yeah, put it on bottom, and it wont popup anymore if this checkbox in options I mentioned is unchecked. Really.
Yeah yeah... I put it on the side bar with resources...
Cause I don't like my code window being reduced to 800 pixels on a 1200p monitor. - AND yes, I know you can hide it the bottom bar even though I never use the bottom bar and think "Why have it if I never use it?" - Also the hide/unhide button prevents you from scrolling on the workspace, further reason why I generally don't like the bottom bar in my prefered layout (which is much more... GM before Studio styled...)
 
Top