• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

SOLVED Version 2.3.3.570 not starting in full screen and audio doesn't stream.

Joe

Member
Every time I start a current project in game maker now, the game doesn't go to full screen. I'm using the windows target, this didn't happen before. It's strange because it starts in a windowed mode. I made a check to switch between windowed and fullscreen, but when it checks, it's apparently already in fullscreen but visibly windowed. After setting to windowed once in game, it will actually go to a true full screen. The game is set to start in fullscreen in the game options. Is this a glitch or do I have to manually set the game to fullscreen now when starting the game, or is their a new option I'm missing, or is this a bug?

This is the check I'm using, so it's definitely returning fullscreen at first when visibly windowed
Code:
        var screen = window_get_fullscreen();
        if screen = true
        {
            window_set_fullscreen(false);
        }
        else
        {
            window_set_fullscreen(true);
        }
I'm also having the issue of streaming .ogg (background music) too, but they run fine when not streamed. Reading under the release notes of this version I noticed this,
  • Building Projects: Now quickly checks .ogg/.wav sounds to see if they are actually valid before passing straight through to your game output folder, will force a recompile if issues are detected
Could someone explain that bullet point a little better? It does seem a little vague as to what makes a .ogg/.wav a valid audio file.
Although the compiler window is not throwing any errors and the game starts, just no audio that is selected to stream.

Any help on these issues would be greatly appreciative and if I was unclear about anything please ask.

Edit: strange, i unchecked "use alternative launcher for steam application" and everything works fine even though this has always been checked. The .ogg audio even streams again. I'm still very curious as to what that bullet point completely means though.
 
Last edited:

Brodie

Member
Strange. I was having the same issue where "Streamed" sounds were no longer playing when the game was launched from the IDE. Unchecking "use alternative launcher for Steam application" fixed it for me as well. Thanks!
Sounds like a bug.
 

ac585318

Member
I was having this issue and some (show_debug_message wasn't working) but this seemed to fix it... GameMaker updates worry me now, lol
 
Top