• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

GMS 2.3+ Verion 2.3.1,Not put in the folder Datafile index

Astorbt

Member
IDE : v2.3.1.542
Runtime : v2.3.1.409

My project is an upgrade from the old version v2.2.5.
I have some special fonts that I have to grab directly from the font file in Datafile with [font_add], but after 2.3.1, this method is not available anymore.
Is there any way to get the project to read back the Datafile, or is this a bug?
 
Last edited:

kburkhart84

Firehammer Games
old version v2.5.1.
I'm guessing you mis-typed your version there. If you meant 2.2.5, then the way addition files(datafiles) works is slightly different now as of version 2.3.0. You no longer have to import them manually into the IDE as part of the project, rather you just put them into the datafiles folder that is under the project file's folder. This is actually better, because if you change those files later, you don't have to re-import or anything like that. I actually have a trick I do with this feature. My input system has a macro defined, that you set to the file path to the project. Then, using that macro(with the sandbox off), you can run a test build and go to the input system configuration rooms. Then the system will save input configurations to the datafiles folder automatically. I found it to be an OK workaround to the lack of IDE plugins, not perfect but it works.

Also, the font_add() function is still in the manual, so I assume it is still working(or should be). I'm also on IDE 2.3.1.542, and it shows up in my auto-complete when I type it in the code editor, so it should still be working fine. If you describe more the issue you are having, if you are getting an error, or exactly what is going on(and show the relevant code), maybe I can offer better help.
 

Astorbt

Member
I'm guessing you mis-typed your version there. If you meant 2.2.5, then the way addition files(datafiles) works is slightly different now as of version 2.3.0. You no longer have to import them manually into the IDE as part of the project, rather you just put them into the datafiles folder that is under the project file's folder. This is actually better, because if you change those files later, you don't have to re-import or anything like that. I actually have a trick I do with this feature. My input system has a macro defined, that you set to the file path to the project. Then, using that macro(with the sandbox off), you can run a test build and go to the input system configuration rooms. Then the system will save input configurations to the datafiles folder automatically. I found it to be an OK workaround to the lack of IDE plugins, not perfect but it works.

Also, the font_add() function is still in the manual, so I assume it is still working(or should be). I'm also on IDE 2.3.1.542, and it shows up in my auto-complete when I type it in the code editor, so it should still be working fine. If you describe more the issue you are having, if you are getting an error, or exactly what is going on(and show the relevant code), maybe I can offer better help.
[/引用]
Technically speaking, after the project is upgraded.
The text is not displayed, and the position where the text was originally displayed becomes transparent and blank.
In version 2.2.5, the draw text syntax can be displayed normally with [font_add].
In version 2.3.1, the same syntax is used, and there are no compilation errors, but the output program does not read or display the text of the font.



I think it's a new version of the bug.


 
Last edited:

kburkhart84

Firehammer Games
Did you check the actual values of the fonts returned from the font_add() function to see if they actually contain added fonts? Also, did you make sure that the font you are trying to add is indeed in the datafiles folder?
 

Astorbt

Member
Did you check the actual values of the fonts returned from the font_add() function to see if they actually contain added fonts? Also, did you make sure that the font you are trying to add is indeed in the datafiles folder?
Checked and confirmed that there is a font return.
It is also in the folder.
 

kburkhart84

Firehammer Games
I don't remember anything changing with 2.3 that affects fonts. You may indeed have found a bug, though I don't know if it is related to the font not being loaded properly, or if it has to do with the drawing. I know regular font drawing still works fine at the least. If you want to make a small test example that does the issue, you can send it my way and see if I have the same issue. It would prove at the least that it isn't your system or files.
 
Top