• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

UWP UWP & XBox \n newline handling issue?

Electros

Member
Hi - posting this here as not sure if there is an issue, or perhaps something up with my implementation.

I'm creating and storing mission info data within ds_maps, and within the BossLoadoutDescription section using \n escape characters.

Code:
        nodeDataMap[? "BossName"] = "Warlord K'thar \"Mega\" Ograrion";
        nodeDataMap[? "BossDescription"] = "Warlord K'thar commands a heavily armed and well armoured battlecruiser. Be especially wary of the impact mine launcher; although low damage, it can knock a ship into the path of destruction.";
        nodeDataMap[? "BossLoadoutDescription"] = "1. 2x Vulcan cannon. \n 2. 2x Capital laser. \n 3. 1x Impact mine launcher";
        nodeDataMap[? "BossIntelPhoto"] = spr_Intel_Shot_Mega;
        nodeDataMap[? "BossPortrait"] = spr_Portrait_Enemy_Pilot_Ogron;
I'm later using this data on the mission briefing screen, creating text and sprite objects from this info. The issue I'm having is that when I'm rendering the text field which contains the \n escape characters, this renders with the text on newlines using PC (both VM and YYC), however on XBox it does not (and is only moving to the next line due to the value set for the text width).

Is there an issue here with the \n escape character handling on XBox, or perhaps a potential issue with my implementation?

PC

PCNewlineHandling.png

XBox One

XBoxNewlineHandling.jpg
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
This sounds more like a bug than a mistake of your code, as \n should work on ALL platforms. Please file a bug report and include a link to a small test project that shows the issue if you could please.
 

Electros

Member
This sounds more like a bug than a mistake of your code, as \n should work on ALL platforms. Please file a bug report and include a link to a small test project that shows the issue if you could please.
Ok, will do that - thanks Nocturne!
 

Electros

Member
Issue reported into the system now (Request #143954) - after putting together a small test project, the issue seems to be with the "ext" draw_text functions on XBox One.

Unfortunately I need the draw_text_ext_transformed_color function in particular for my UI, but nice to know I'm not losing the plot!

NewlineTextTestXBoxOne.jpg
 
A

Agreeable

Guest
I was thinking more from the perspective of trying that instead of \n, to see if that fixes your problem. But it appears that things have changed in GMS2.
 
Top