• Hey! Guest! The 37th GMC Jam will take place between May 28th, 12:00 UTC and June 1st, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

UWP UWP Igor "System.Exception: unable to install app on device" when trying to run on Windows

Jon

Member
I've got a game that I can deploy to xbox but can't run locally on the PC. Until a couple days ago, this worked.
I get this problem for VM or YYC.
This is after the build, on the deployment.
X:/bin\dpdeploy.exe -s -c "C:\Users\jonpu\AppData\Local\Temp\dpdeploy-container-ac128552abcda8258e58150177600912" -h=localhost:50443 -u=jon_gms -p=xxxx list-apps
System.Exception: unable to install app on device
at Igor.WinUWPBuilder.DoInstall(String packageFullName, String appx_path, String certificate_path)
at Igor.WinUWPBuilder.BuildWindowsUAPProject(String package_name, String _targetfile, Boolean _final)
at Igor.WinUWPBuilder.Run()
Igor complete.​

IDE 2.2.0.343
Runtime 2.2.0.258
Windows SDK 10.0.17763.0

Today I switched to the real MS Store cert for the game, but that made no difference in this problem.
Again, I can build for submission to the store and I can deploy to xbox.

Pulling my hair out on this. HELP!!!! :)
 

Jon

Member
OK, I may have solved my own problem.
I built the UWP executable (the .appx). When I tried to install that on my laptop (the same one that I built it on) by double-clicking on the APPX file, I got this error code: 0x80073CFD.
After some googling about, I found a reference to checking the Windows event log under Application and Services Logs -> Microsoft -> AppXDeploymentServer - > Microsoft0Windows-AppXDeploymentServer/Operational.
And lo and behold, I found this error:
AppX Deployment operation failed for package 12160PocketApps.Larceny_1.1.8294.0_x64__b8r70j6by0mm6 with error 0x80073CFD. The specific error text for this failure is: Windows cannot install package 12160PocketApps.Larceny_1.1.8294.0_x64__b8r70j6by0mm6 because this package is not compatible with the device. The package requires OS version 10.0.17763.0 or higher on the Windows.Universal device family. The device is currently running OS version 10.0.17134.345.
So the issue was that I set the "Windows Target Platform Version" and "Windows Target Platform Min Version" in the GMS project UWP options to be the same - 10.0.17763.0. This works fine for the Xbox but not for my laptop.
I set my "Windows Target Platform Min Version" to be 10.0.17134.0 and now everything is groovy.

HOWEVER, it seems pretty lame that GMS did not surface this error code from installing the AppX when I was trying to run from inside the IDE. A lot of frustration would have been saved if it had simply done that.

I hope this helps someone in a similar situation.
 
Top