• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Question - IDE Updated today, GM:S2 crashed, now I can't run the game

Bee

Member
I've submitted this to support, but I'm curious if I've done something wrong that some of you kind people can help me out with. I'm desperate.

I updated to the latest version today, experienced two GM:S2 crashes. After the second, the game would no longer run giving me the following info in the Output window:
C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.0.4.42/windows/Runner.exe exited with non-zero status (-1073741819)
elapsed time 00:00:17.7956326s for command "C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.0.4.42/bin/Igor.exe" -options="C:\Users\<name deleted>\AppData\Local\Temp\GameMakerStudio2\build.bff" -- Windows Run started at 02/24/2017 14:10:24
FAILED : Run Program Complete

I've tried the following things:
- Removing the last object created, same issue
- Restarting my computer, same issue
- Running an older version of the game, it works
- Deleting the asset cache, same issue

Sadly the last time I made a backup was last week, and I've done a LOT of work since then. I've learned my lesson to backup more often.

Does anyone know if I've done something wrong, has my game been permanently corrupted, or is it just a bug that YoYo Games can fix?

Thank you thank you thank you.
 

babyjeans

Member
You're running an old runtime... Under File->Preferences->Runtime Feeds->Master you'll see a "New Version" drop down. Make sure 2.0.5.47 is selected.
 

Bee

Member
You are a beautiful, magical, incredible creature. May the gods shine their light on you forevermore. I CANNOT thank you enough. I'm almost crying.
 
Top