Android Updated to Target 28 Android

kupo15

Member
I'm confused on what I'm doing wrong. I'm trying to put something on the play store but apparently I'm not targeting the latest devices. Currently targeting 23 but it needs to be 28.

I change my settings to 28 but the compile fails
upload_2019-11-23_19-33-37.png


I believe I have the right sdks, target 23 works
upload_2019-11-23_19-34-13.png

upload_2019-11-23_19-34-45.png

upload_2019-11-23_19-38-9.png


What am I doing wrong? Do I need to update the SDK location as well? Do I need to do something with the NDK or JDK? This is all foreign to me
 

Mert

Member
What does the compile log says? What's the error?

And that version is way too old, it's not Game Maker Studio 2!
 

kupo15

Member
What does the compile log says? What's the error?

And that version is way too old, it's not Game Maker Studio 2!
Sorry, the legacy forum is going away and didn't now where else to go. I only have android for 1.4

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring project ':com.companyname.Mexico_Golf'.
> Could not resolve all dependencies for configuration ':com.companyname.Mexico_Golf:_debugApkCopy'.
> Could not find com.android.support:support-v4:28.1.1.
Required by:
project :com.companyname.Mexico_Golf

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 3.579 secs
cmd /c "subst /d Z:"

Lint Build report available at C:\Users\lemme\Documents\GameMaker\Cache\Mexico_Golf\Android\Default\com.companyname.Mexico_Golf\build\outputs\lint-results.html
Create finished: 7:44:38 PM
 

kupo15

Member
Legacy forum is going away, but the technical subforum will not.

As for your question, it obviously cannot find your Android Support Library. Try 28.0.1
Ahh sorry, maybe @Nocturne can move this thread there.

Tried it and still failed
FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring project ':com.companyname.Mexico_Golf'.
> Could not resolve all dependencies for configuration ':com.companyname.Mexico_Golf:_debugApkCopy'.
> Could not find com.android.support:support-v4:28.0.1.
Required by:
project :com.companyname.Mexico_Golf

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 10.942 secs
cmd /c "subst /d Z:"

Lint Build report available at C:\Users\lemme\Documents\GameMaker\Cache\Mexico_Golf\Android\Default\com.companyname.Mexico_Golf\build\outputs\lint-results.html
Create finished: 8:00:56 PM

Is my path to the sdk not correct?

And here is what is in that folder
upload_2019-11-23_20-2-29.png


EDIT:

Figured it out! The support build was supposed to be 28.0.0. Thanks for pointing me in the right direction!

I guess I have to get it for GMS 2 because Googleplay requires 64 bit. Darn. Oh well I guess its a good investment, now I can fully migrate to GMS2
 
Last edited:
Top