OFFICIAL Updated Forum Issues

Tthecreator

Your Creator!
for what ever reason

https://forum.yoyogames.com/index.php is always shown as secure

but at random some treads make chrome think the sight is not secure, it doesnt prevent me from accessing the thread but it does give pop ups saying the site is not safe.

View attachment 29229
This may be because someone included different images (or other content) from http:// sources.

Here is an image that is loaded via http:

 

Let's Clone

Member
I'm hoping this is the right place to mention this, but it's the only bug that I seem to notice.

The issue is when I'm typing. More specifically, when I'm backspacing through a word. Typically, I can backspace through an entire word, stopping at the space, and continue typing. However now when I delete the first letter of the word, the backspace input automatically deletes the preceding space character and the cursor jumps to the end of the previous word. Oddly, this only happens once in a while and I notice it the most during dm conversations.

Has anyone else experienced this? It happened to me 3 or 4 times while typing this out haha.
 

Roderick

Member
Regarding the collapsing forum sections:

On my phone, I keep them all collapsed, because I'm usually just checking recent posts and profile posts, and don't want to scroll past everything to get to the profile posts.

When I'm away from the forums for a significant amount of time (typically the first visit of the day), all the sections are un-collapsed. Since I'm not getting logged out, I don't think it's cookie related.

I cannot say if it's happening on desktop; I keep everything at default there.

Using Samsung Internet on Android 10 on a Note 10+.
 

DarthTenebris

Definitely not a Sith Lord
Not sure why that is or if there's anything I can do about it, since this will be the forum software. But I'll see if there's and option in the Admin CP for it.
How's it going there? I would really love to have that button there, makes navigating the pages just that much easier, since changing pages places the scroll at the top by default, while the buttons are at the bottom. On PC the buttons are there, and if they're not I can just press Ctrl + End. Not the case for mobile.

EDIT:
I might also have found a minor glitch: In a multi-page thread, when you're anywhere other than the last page, and you make a post on the thread, the post you made will be placed on the bottom of the page anyway. Really not a big deal, just thought it might be worth saying.
 

SSJCoder

Member
not sure if mentioned before, but YT videos linked seem to give a (very) low res thumbnail image in status updates
 

Yal

🐧 *penguin noises*
GMC Elder
Firefox explicitly points out that images are insecure, so it's just Chrome that wants you to be more anxious.
1584294318552.png




Any chance we could get post counts back into the per-post info dump? It's still shown if you view someone's profile, but it's so hidden away that it's easy to miss altogether. While post counts aren't a be-all, end-all measure of seniority and skill, it's pretty good for quick judgment on what familiarity level to answer a GML- or community-related question alongside the post you're replying to. (Also, having a number that goes up and is shown publicly everywhere is an incentive for people to be active on the forum)

Example picture:
1584294435920.png
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
The issue is when I'm typing. More specifically, when I'm backspacing through a word. Typically, I can backspace through an entire word, stopping at the space, and continue typing. However now when I delete the first letter of the word, the backspace input automatically deletes the preceding space character and the cursor jumps to the end of the previous word. Oddly, this only happens once in a while and I notice it the most during dm conversations.
I haven't seen this issue and have no idea what could be causing it for you. Certainly, there are no settings in the admin CP for anything related to it...

When I'm away from the forums for a significant amount of time (typically the first visit of the day), all the sections are un-collapsed. Since I'm not getting logged out, I don't think it's cookie related.
According to the forum software, this is governed by cookies and nothing else, and there is no option to make it a user profile thing that is maintained across devices or sessions.

I might also have found a minor glitch: In a multi-page thread, when you're anywhere other than the last page, and you make a post on the thread, the post you made will be placed on the bottom of the page anyway. Really not a big deal, just thought it might be worth saying.
That's a bit weird, but again, that seems to be just how the forum works...

not sure if mentioned before, but YT videos linked seem to give a (very) low res thumbnail image in status updates
Sorry, like all of the above, this is just the way it is and nothing I can do about it.

Any chance we could get post counts back into the per-post info dump? It's still shown if you view someone's profile, but it's so hidden away that it's easy to miss altogether. While post counts aren't a be-all, end-all measure of seniority and skill, it's pretty good for quick judgment on what familiarity level to answer a GML- or community-related question alongside the post you're replying to. (Also, having a number that goes up and is shown publicly everywhere is an incentive for people to be active on the forum)
I'll see what I can do, as I do like having the extra information there and we do have a lot of empty space that could be put to good use that way.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Still no cursor in code editor on firefox (I've tried hard refresh to be sure).
OKay, thanks. I'll keep looking at that as it should be visible. I don't have firefox installed to test, but I'll get it so I can get a clearer idea of what the issue could be.
 

chance

predictably random
Forum Staff
Moderator
Still no cursor in code editor on firefox (I've tried hard refresh to be sure).
Using Firefox 74.0 (64 bit) here. I only see this problem with the light skin. The cursor is visible in the code editor with the dark skin. (EDIT: as you reported in your earlier posts.)

And just to be clear, this applies only to the code editor window. Once the code has been inserted into the post, the cursor is visible in all skins.
 

EvanSki

King of Raccoons
for what ever reason

https://forum.yoyogames.com/index.php is always shown as secure

but at random some treads make chrome think the sight is not secure, it doesnt prevent me from accessing the thread but it does give pop ups saying the site is not safe.

View attachment 29229
This may be because someone included different images (or other content) from http:// sources.

Here is an image that is loaded via http:

Firefox explicitly points out that images are insecure, so it's just Chrome that wants you to be more anxious.
View attachment 29416




Any chance we could get post counts back into the per-post info dump? It's still shown if you view someone's profile, but it's so hidden away that it's easy to miss altogether. While post counts aren't a be-all, end-all measure of seniority and skill, it's pretty good for quick judgment on what familiarity level to answer a GML- or community-related question alongside the post you're replying to. (Also, having a number that goes up and is shown publicly everywhere is an incentive for people to be active on the forum)

Example picture:
View attachment 29417
I figured it out. Its an issue with the sites cookies.
1.png
2.png

[edit 4/3/20] google really has a lot of issues with this sites cookies, its even denying some to even load, i have no settings to prevent cookies on this site, so its not my settings causing the issue
 
Last edited:

O.Stogden

Member
Not sure if it's been mentioned, but I don't believe the "420" character limit on profile posts is accurate.

At least when I used a couple of character counters on other sites, I had to get it to below 400 before I was allowed to post.
 

Yal

🐧 *penguin noises*
GMC Elder
I always assumed the 420 was a "420 blaze it" joke and not actually enforced. But that aside, anything outside the standard ASCII range (e.g. emojis, most accented characters) secretly take up multiple bytes, so it might count towards multiple characters even though it renders as one, depending on how the counters are implemented. Unicode still isn't transparent for most common languages, it's that "weird" text while ASCII is normal text.
 

GMWolf

aka fel666
I feel like 420 is too short a limit. It doesn't seem to like a sensible thing to have in the first place. All it does is get people slightly over the limit to spend time shortening their post (only saving a few bytes anyways) or make people split up their posts, saving nothing and wasting time.
 

EvanSki

King of Raccoons
I for one would just like the counter back to know if im currently going over the limit and by how much
 

gnysek

Member
OKay, thanks. I'll keep looking at that as it should be visible. I don't have firefox installed to test, but I'll get it so I can get a clearer idea of what the issue could be.
Cursor is still not visible on Firefox in code editor (light skin).
CSS:
.codeEditor.CodeMirror.CodeMirror-focused { background: white; }
should solve it
 

TailBit

Member
I usually do like my text pretty small, but now I'm not able to read the "inline code" and "code" (the CODE=gml is fine) unless I get really close to the screen, 2 examples with some default text in view, with the default chrome zoom:

a1.png
a2.png
.. on phone they look fine and readable.

EDIT: seems this font issue is that I have multiple monospace fonts installed cause I was making a pixel game, in combination with a bug on chrome that does not choose the monospace that is set as default .. fixed with an addon for now.
 
Last edited:
@Nocturne would it be possible to have the page navigation widget duplicated on the top of a thread when on mobile? I personally find it very annoying that I have to scroll all the way down on a long thread just to be able to navigate between pages (e.g. the last page). If there is no configuration for it then I can live with it, just that it would ease mobile navigation for me personally
 
@Nocturne would it be possible to have the page navigation widget duplicated on the top of a thread when on mobile? I personally find it very annoying that I have to scroll all the way down on a long thread just to be able to navigate between pages (e.g. the last page). If there is no configuration for it then I can live with it, just that it would ease mobile navigation for me personally
The odd thing I notice on mobile is that in landscape mode, the page widget is there at the top just not in Portrait mode.
 

gnysek

Member
@Nocturne I'm still waiting for this fix for light skin on forum:
CSS:
.codeEditor.CodeMirror.CodeMirror-focused { background: white; }
as I still see no cursor in code editor.
 
Top