Distribution Unable to Upload to the Marketplace

Hello,

I created a rather large asset which I would like to upload to the Marketplace. When I tried uploading from GMS:2, the upload failed with an error message saying "The remote server return an error: (413) Request Entity Too Large." Evidently, the server isn't willing to take my file size. I'm not sure what the size limitation is. When I export the same project, the file size is 46.6MB

Anyway, I noticed that there is a spot in the developer console under "Versions" when you can upload a new version, so I thought that maybe I could upload my project that way. It doesn't indicate what type of file is needed, so I thought I would try my 46.6MB .yyz package. No luck. It says "You must select the correct GameMaker Studio asset."

I'm stuck. Any help??
 
Update:

I looked up the asset cache directory (from preferences > general settings > paths), and visited that directory. In there, I found a yymp file the size of my game package, so I tried uploading that to the publisher console. It took the file! However, when I tried to click "save" it gave an error saying "error 503 backend fetch failed" Apparently, this error means that the server isn't functioning. I'll try again later and hopefully I will be able to get through.
 
Top