• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

 Unable to test run any projects

T

Tankwars

Guest
Just installed version 2.0.6.93 of GMS2 (was using version 2.0.5.49 previously), and I am unable to test run my projects at all. Attempting to test projects on Windows and HTML5 only pops up one message in the compiler window saying that it's saving the project, like this:

'Saving project to: C:\Users\Tankwars\Desktop\GameMaker Studio 2\Projects\TestGame\TestGame.yyp'

Then nothing else happens, when I try to run the game again (even after pressing the stop button), it pops up a confirmation box saying, 'Stop the current running project before running again?'. Still won't run the game afterwards, just comes up with, '---------- STOPPING ----------'.

I am running GMS2 on Windows 7, and nothing I've done so far has made solved the problem, I've already tried:

1) Reinstalling the program (3 times).
2) Restarting my PC.
3) Switching to different runtimes in preferences.
4) Clearing GMS2 related files in Appdata in windows explorer.
5) Creating a completely new project and running it (doesn't run, same problem)
6) Tried running in administrator.

So I have no idea what is wrong here. This started today when I was editing a trivial bit of code to do with camera views. I went to press Run to test the game, but cancelled it because I wanted to quickly change something, I also clicked the 'clear cache' button. Then when I went to press play, all this happened.

Debug mode has the same problem.

Help would be appreciated here :/
 
T

Tankwars

Guest
I've been there already I think, I don't understand why it doesn't work :/

Posted a screenshot to confirm if it's the right place:

Untitled-1.png
 
J

Jehal

Guest
I also had this issue after the Game Maker 2 update on Steam.
I was super confused for a while since there was no feedback at all when trying to run. It is a minor issue, but some form of notice would have been helpful.
Changing to the newest runtime also fixed it for me.
 
T

Tankwars

Guest
I don't have GMS2 on Steam, just the standalone version, so I'm wondering if that's why this solution doesn't work for me.

Very frustrating that the main solution yields no results for me :(
 
T

Tankwars

Guest
Ok, finally managed to get it to work.

For those still having issues (Windows users), try going into C:/ProgramData/GameMakerStudio2/Cache/runtimes. Delete every single runtime version in that folder, then launch GMS2. The software will install the latest runtime version automatically, but will for some reason now work when you test your projects. Hopefully it doesn't somehow come back again. :cool:

If you don't see the ProgramData folder, you will need to enable 'show hidden files' in windows explorer.
 

Quazeye

Member
Ok, finally managed to get it to work.

For those still having issues (Windows users), try going into C:/ProgramData/GameMakerStudio2/Cache/runtimes. Delete every single runtime version in that folder, then launch GMS2. The software will install the latest runtime version automatically, but will for some reason now work when you test your projects. Hopefully it doesn't somehow come back again. :cool:

If you don't see the ProgramData folder, you will need to enable 'show hidden files' in windows explorer.

Thanks... I have this issue and will try this when I get home tonight.
Q
 
Y

yanko

Guest
Had the same issue but was able to fix it thanks to the instructions posted.

On another note, is it possible to disable autoupdate from the software? I was unable to launch it without updating. I do not care about minor fixes and I do not want to waste 20 mins every time there is a random update that is going to present problems like this.

Thanks
 

rwkay

YoYo Games Staff
YYG Staff
As stated in the release notes we had to make licensing changes which requires this to be a mandatory update, we do not do this lightly and only when server side changes require the IDE to be updated - we hope that this not required for a long time into the future but we cannot guarantee this.

Russell
 
P

PandaPenguin

Guest
I'm still unable to run any projects... wtf...:eek:

tried all the solutions listed here but no success with F5 or F6

it's the standalone version and even when I try to compile as YYC nothing happens (worked prior to the update)

GMS2_error1.fw.png
as you can see in this screenshot the compiler is set to latest version and I also deleted all previous existing compiler instances in the folder by hand and let GMS2 re-download/install the latest compiler version

any other solutions??

this issue is costing me real money as I can't keep my deadline if this problem persists

EDIT:
apparently cleaning the registry (with CCleaner) did the trick combined with a fresh install of GMS2 Desktop
https://forum.yoyogames.com/index.php?threads/solved-runtime-2-0-6-93-not-working.26530/
 
Last edited by a moderator:

rwkay

YoYo Games Staff
YYG Staff
I really do not understand why a registry cleaner helped as we do NOT use the registry at all in GMS2 (as the IDE works on a Mac, we could not rely on having the registry)... and an update does the uninstall first, I suspect something else is causing a problem underlying this...

Russell
 

Mike

nobody important
GMC Elder
It might have tracked the "installed" program location (from the start menu and where uninstall is run from), but aside from that - there's nothing to actually clean.
 

rIKmAN

Member
It was me who suggested CCleaner as the problem in that thread was localised to a single machine and GMS2 worked on others he had.

It wasn't to specifically remove any GMS2 related stuff, but to tidy up any crap on that machine that might be stopping GMS2 working.

Even though I asked early on about Windows being up to date, it turned out in the last post that he hadn't installed the Creators Update so I assume it might be something to do with that.
 
Top