• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Question - IDE Unable to login - No network connection

Status
Not open for further replies.

FinalQ

Member
Almost always this error - "Unable to login - No network connection".
Because of this, I can neither login nor updated.

I wrote to tech support - to sense 0. Maybe somebody, a similar problem arose?

No, I do not use a proxy, vpn, more nibud any special settings.
I work under win10, everything else software is working properly!
 

Cpaz

Member
Have you checked your firewall? You may have not set that up properly when starting it up for the first time.

But when all else fails, try reinstalling.
 

FinalQ

Member
I have created the rules, as well as to disable the firewall. This does not work.

Reinstalling does not help.
 

FinalQ

Member
How Do GMS2 internet access checks whether or not there? Not quite clear because the rate of occurrence of a error - instantaneous. He did not check at all.
 

rwkay

YoYo Games Staff
YYG Staff
We check to see if there is a network adapter that thinks it is connected to anything at all and then check for internet connectivity using well known websites (i.e. www.google.com, yahoo.com etc. etc) if we cannot sense any of them then we deem the internet to be unavailable.

I wonder why you are getting this, can you please open a ticket at http://help.yoyogames.com/bug2 and attach the ui.log from %ProgramData%/GameMakerStudio2 as this should help with working out what is wrong and why

EDIT: Could you also include which area of the world you are in???

Russell
 

FinalQ

Member
Could you also include which area of the world you are in???
I login from Russia

[12:29:38:336(f4e6)] ************************************** 02/19/2017 **************************************
[12:29:38:342(f4e6)] Log.Initialise
[12:29:38:343(f4e6)] GameMakerStudio, Version=2.0.4.64, Culture=neutral, PublicKeyToken=83c29ed24e39e35e
[12:29:38:343(f4e6)] Initialise()
[12:29:38:513(f4e6)] File exception 'Could not find file 'C:\ProgramData\GameMakerStudio2\Cache\Survey\surveys_done.json'.'
[12:29:38:739(f4e6)] File exception 'Could not find file 'C:\ProgramData\GameMakerStudio2\Cache\Survey\survey_dismiss.json'.'
[12:29:38:795(f4e6)] File exception 'Could not find a part of the path 'D:\GameMaker-Studio-2\user_cache_directory\Styles'.'
[12:29:38:946(f4e6)] File exception 'Could not find file 'C:\ProgramData\GameMakerStudio2\org_settings.json'.'
[12:29:38:946(f4e6)] File exception 'Could not find file 'C:\ProgramData\GameMakerStudio2\machine_settings.json'.'
[12:29:40:793(f4e6)] Shader 'standard_shader' loaded.
[12:29:40:793(f4e6)] Shader 'standard_flat_shader' loaded.
[12:30:03:782(f4e6)] ResourceManager resources have been cleared

We check to see if there is a network adapter that thinks it is connected to anything at all and then check for internet connectivity using well known websites (i.e. www.google.com, yahoo.com etc. etc) if we cannot sense any of them then we deem the internet to be unavailable.

I wonder why you are getting this, can you please open a ticket at http://help.yoyogames.com/bug2 and attach the ui.log from %ProgramData%/GameMakerStudio2 as this should help with working out what is wrong and why
I wrote a ticket a few months ago. At the time, the problem goes away by itself. And I did not change any settings in the system. Now, when the login cache time is up, the problem came back again. This is most likely due to the availability Valid some popular sites...
I will try to set up VPN tunnel, in which case it should help?
 

FinalQ

Member
Oh yeah. I set up a VPN tunnel and could easily log in. But it is not normal!

Can I hope that will be revised method for checking the availability of the Internet in GMS2? Because 1.4.x versions work fine.
 

rwkay

YoYo Games Staff
YYG Staff
Hmmm can you contact me via DM and I will look to get you a new version with extra debugging so I can see what is going on

Russell
 
A

Andrew Wooldridge

Guest
I am also experiencing this problem now. I used to be able to log in and use it just fine. I went for a few weeks without launching it (this is from steam) and now it always says "network unavailable unable to login". Any advice would be great as this is preventing me from launching at all.
 
D

David Montgomery-Blake

Guest
I'm seeing this too (in Nevada). I just installed on this machine through Steam and cannot login. 1.4 works fine, as does everything else. I'm writing this comment while it still will not connect.

No firewall strangeness, VPN, etc. Steam downloaded an update to a game, so it's seeing things correctly. Adobe Creative Cloud and my Maya subscriptions passed checks.

It is currently unusable on my primary machine.
 

Mike

nobody important
GMC Elder
If your on Steam, make sure you're friends list is on line and signed in. This is the only way Steam lets us do online/offline checking.

We're removing this next version as it's just too problematic. If you want to be offline, switch off networking.
 
M

Mastergidan

Guest
If your on Steam, make sure you're friends list is on line and signed in. This is the only way Steam lets us do online/offline checking.

We're removing this next version as it's just too problematic. If you want to be offline, switch off networking.
Hi Mike, I got the software from your website so it's not the Steam version but of course I'm on Steam as user too, I really don't know why but it seems to be solved for no reason at the moment, so the software is now running correctly for me anyway I've attached my ui.log in the report I made before through the helpdesk.

Yesterday I was trying to upload a new Extension for GameMaker Studio 2 on the Marketplace but it was not loading my Extensions in the Upload Existing Package window (probably because I was not logged in for the software), so I've just logged out the account and then this problem happened.

I've also turned off internet connection but the software was keeping crashing at start or doing the same.

I've also tested an older version but it was giving the same issue.
 
Last edited by a moderator:

Mike

nobody important
GMC Elder
I was referring to David's post above. There are cases where the underlying internet in .NET is just broken, and we don't yet know why. Checking for stuck tasks in the task manager - or resetting should fix these though.

While we occasionally see the issue here, we've never been able to catch it in the debugger, so are still at a loss. We are still looking into it though.
 

Vince3006

Member
I had the same issue. I wont go through all the darn command line stuff to find it but this is how I fixed it.
Google Play Console
Upload new release (alpha, beta, closed, whatever).
Before rolling it out, save as draft.
Game Services--> Your App--> Linked Apps.
Click on your app linkages.
One by one of the same app if necessary and delete.
Create a new Client ID (Linkage) and accept default SHA1 code.
Finish release roll-out.
I made sure correct version was downloaded/Installed from Playstore and everything worked.
I really hope this helps people, it's one of my first posts.
 
Status
Not open for further replies.
Top