• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Unable to login anymore

Z

Zesquonk

Guest
Hi, I have been using Game Maker 2 for more than one month now and I use it from my steam account.

Since yesterday I was able to login to use Game Maker 2 and learn how to use this software step by step. But since yesterday I can't login anymore, I always have the message "Unable to login – no network connection" when I try to use GM2. I have tried to shut down my firewall and my antivirus and nothing happen, still unable to login.

I can access everything else, internet, my online steam games, my e-mails... except my login of GM2.

When I go to my Yoyo account I can see the last login sessions and I see that a login session has been registered for yesterday from my computer so somewhere the server knows that I logged but still send me this "no network connection".

What is going wrong ? I have changed nothing on my computer and suddenly I can't access my software anymore :

- zero access to my lines of code
- zero access to GM2 at all.

That's rather frustrating to have zero access to your software due to the fact there is a login trouble, it's even more than that, the fact I can't even access my lines of code, just to take time to think about how to improve them is somehow not normal.

Did this already happened to other people and how can someone tell me what to try to be able to login again on my software ?
 
I sometimes have a similar problem. One workaround I use is to disable my computers network connection. Then open GMS 2. It usually lets me straight in. Then I re-enable my network connection.

I think you have to have logged in successfully at least once online. Then your login credentials are cached locally for a month(or 2 weeks? not sure how long).

Once the time period is up and your locally cached credentials have expired, this method might not work.

Don't quote me on the accuracy of the above information though. Just thought this might help you get back into your software for now.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
You should contact the helpdesk and ask for support. This is not something that should happen if you are using the Steam version.

Don't quote me on the accuracy of the above information though
@IndianaBones : Your post is accurate for the standalone version. Not sure what the situation with Steam is though... I would imagine if you have Steam in offline mode for more than a few weeks then you would probably need to connect to relicense too though
 

Dan

YoYo Games Staff
YYG Staff
I suspect that this is just that the IDE will now respect your Steam online/offline status, which is a new change in 2.0.6. You will need Steam to be in online mode, otherwise the IDE won't try to do online functionality.

Can you confirm that your Steam client is in online mode and that you are signed-in to the social/friends system (Steam classes this as online...). If not, turn these on and please confirm this fixes for you.
 
Z

Zesquonk

Guest
Ok, so when I'm in steam online but I ask steam to show me like if I am offline I wont be able to open GM2 and to login ?

I usually am always online with steam, but I am showed as offline since I think it's a question of private life....

Anyway I will try to do the trick and to show me as online on steam.

Edit :

Ok now I can login the server again and use GM2 again when I show me as online on Steam.

So will this be permanently this way ? We will have to show us as online on Steam to be able to use the software ?
 
Last edited by a moderator:

Mike

nobody important
GMC Elder
You'll need to be "online" about once a month - to re-validate your license. If you put Steam into offline mode, then the IDE is also put into offline mode. So every now and then just start online and it should update, and you can stick it back to offline again.
 
Z

Zesquonk

Guest
Good to know, thanks for the info so it's not a problem anymore.

Have a nice day.
 

Micah_DS

Member
Ah! I wondered why the Steam version was saying I had no internet connection while the non-Steam version logged in just fine. Putting my Steam status to online fixed it immediately, as expected.

Glad I saw this topic. Cheers!
 
Top