Unable to find output device "null"

Discussion in 'Legacy GameMaker Community Tech Support' started by Brandon Paris, Feb 26, 2018.

  1. Brandon Paris

    Brandon Paris Member

    Joined:
    Dec 2, 2017
    Posts:
    10
    Hey everyone, so I made the mistake of updating GMS and since have recieved the compiling error:

    Unable to find output device "null" defaulting to "Speaker/HP (Realtek High Definition Audio) via DirectSound"

    When I play my game, it seems to be clipping my sound effects. It's incredibly annoying. Does anyone know how I can fix this? I can't seem to find any option to set my output audio device to anything

    Thanks!
     
  2. Mick

    Mick Member

    Joined:
    Jun 30, 2016
    Posts:
    719
    I don't know how you can fix it other than downgrading GMS. The audio engine for Windows has changed in the newest version. From the release notes:
     
  3. Nathan Laing

    Nathan Laing Member

    Joined:
    Jul 31, 2016
    Posts:
    355
    I also made the mistake of updating GMS, and get the error [Unable to find output device "null" defaulting to "�X�s�[�J�[ (Sound Blaster Z) via DirectSound"]
     
    Last edited: Mar 29, 2018
  4. Dawn DeerButt

    Dawn DeerButt Member

    Joined:
    May 3, 2018
    Posts:
    6
    ive started getting this error in my game and im not even using audio in my game yet
     
    Nathan Laing likes this.
  5. Nathan Laing

    Nathan Laing Member

    Joined:
    Jul 31, 2016
    Posts:
    355
    This issue has still not been fixed in the latest update. :(
     
  6. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    4,317
    Is the audio device set correctly in preferences?
     
  7. Nathan Laing

    Nathan Laing Member

    Joined:
    Jul 31, 2016
    Posts:
    355
    I don't know what you refer to, there are no options for configuring sound devices in the Gamemaker preferences that I can see.
     
  8. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    4,317
    File > Preferences > General Settings

    Check the default audio device.
     
  9. Nathan Laing

    Nathan Laing Member

    Joined:
    Jul 31, 2016
    Posts:
    355
    I spent 5 minutes looking through there, there is no option. This is GMS1.4
     
  10. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    4,317
    Ah my bad, didn't notice this was in the legacy forum.
     
  11. Nathan Laing

    Nathan Laing Member

    Joined:
    Jul 31, 2016
    Posts:
    355
    This bug is killing me. Surely there must be a simple fix, it never used to do this.
     
  12. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    4,317
    What version of 1.4 are you using?
    Are your sounds still being clipped or are are they playing normally but still giving the message?

    This post seems to indicate it's only a diagnostic message and if sound is playing then things are normal.

    Have you played around with the sound settings for the clips (compressed / uncompressed / streamed etc) or tried converting them to a different format (mp3/wav.ogg) to see if that changes anything?
     
  13. Nathan Laing

    Nathan Laing Member

    Joined:
    Jul 31, 2016
    Posts:
    355
    1.4.999
    If it's only a diagnostic message, it's no big deal. But Gamemaker crashes 80% of the time on Game End, even on empty projects. I thought it might be a related issue.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice