• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Question - IDE Unable to find game::Name.win

Greg20203

Member
Hey,
Hey, sorry for my English at the start.
My problem:
When i try Run my project(game), I have an error "Unable to find game!!: Myname.win"
I tried reinstall, I installed in differents discs, I cleaned %appdata% after reinstall, later again. I tried to change to a different version (I have the latest one). Umm.. I maked many projects and always the problem is the same. TEMP and Cache are on the same disc.
I have trial version from official page. Can anyone help me?
My system: Windows 7.
 

TsukaYuriko

šŸŒ 
Forum Staff
Moderator
Please disable all antivirus and firewall software when running the game. Does the problem persist? (This is not a permanent solution - just checking possible culprits.)
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
@Greg20203 @Kunaya You should both file tickets with the YYG helpdesk. This issue is usually caused by something locking the files (like an anti-virus or a cloud app like DropBox), but if you have none of these active or have discarded those options as being the cause of the problem, then really only the YYG support team can help.
 
I too am having this problem. I did find this article in regards to changing the size of the CMD window but so far this method has not solved my problem:
https://forum.yoyogames.com/index.p...e-receive-unable-to-find-game-game-win.67484/
Perhaps it may help someone here.

I too am using IDE v2.2.5.481 and Runtime v2.2.5.378 and the most current Visual Studio files that are relevant.

I have exported my project using multiple methods on my laptop, which I have been building my game on.

The problem is now occurring on my desktop machine after importing my game. All of the assets of my game are present and the import appears to be a success however whenever I attempt to compile any sort of build of the game I too am seeing the dreaded error window reading "Unable to find game!!: Myname.win" . IDE and Runtimes on both machines are identical so I'm sure that is not the problem.

I will continue to troubleshoot the problem and post my findings here upon any success in solving this.
 
UPDATE:

Ok, so I finally got to the bottom of this one :)

Changing the size of the cmd window did solve the problem but with a twist.

The article shows how to create a shortcut on the desktop that will open the cmd window then set the size properties of the window once it opens. My problem was that every time I attempted to do this the command window would open then close itself immediately without applying the change to the window size. Troubleshooting why this was happening lead me down a rabbit hole which eventually revealed that my machine was infected with malware that slipped my anti-virus service and firewall. This malware apparently prevented the cmd window from opening and would terminate the program immediately.

This turn of events exposes some serious security concerns prompting me to invest in additional malware protection. Even though Windows does not suggest this, I went ahead and used a program to clean my registry, just as a precaution. After solving multiple problems that I didn't even know that I had, I attempted to compile once more, this time to success. My game finally compiled and launched!

I have tried everything from reinstalling Gamemaker Studio 2 and Visual Studio to exploring the plethora of exporting/ importing options. Welp, turns out the problem wasn't with my game or how I chose to migrate my project, it wasn't even Gamemaker this time (I'm joking ;)). I'm glad to have gotten past this little hiccup and can finally get back to development.
 
Top