1. Hey! Guest! The 36th GMC Jam will take place between February 27th, 12:00 UTC - March 2nd, 12:00 UTC. Why not join in! Click here to find out more!
    Dismiss Notice
  2. NOTICE: We will be applying a Xenforo update on Tuesday 25th of February. This means that from approximately 10:00 to 14:00 BST the forums will be offline (or possibly longer). Sorry for the inconvenience! Official Announcement here.

Mac OSX 'Unable to find game!!" error message

Discussion in 'GameMaker Studio 2 Community Tech Support' started by dannyjenn, Jan 22, 2019.

  1. dannyjenn

    dannyjenn Member

    Joined:
    Jul 29, 2017
    Posts:
    583
    I'm having the same problem as was brought up in this other thread in the Legacy version forum:
    https://forum.yoyogames.com/index.p...-compiling-uploading-and-redownloading.26675/

    I'm on Mac...

    IDE Version: 2.2.1.375
    Current Runtime: 2.2.1.287

    I export my game to *.app. Everything works fine... the *.app runs on my computer without a problem. I compress (*.zip) the game and upload it to Google Drive. I then re-download, unzip it, and try to run it, and I get an error message "Unable to find game!!"

    This isn't too big of a deal since (as was pointed out in the other thread) if you put the game into a *.dmg rather than a *.zip then it won't have this problem.

    Still, I'm wondering whether YoYo Games has any plans on fixing this problem, or whether there is any way that I could prevent the *.app from getting messed up when I zip it.
     
  2. Samuel Venable

    Samuel Venable Time Killer

    Joined:
    Sep 13, 2016
    Posts:
    1,307
    Moving the app out of the Downloads folder after extraction fixes it for me.

    PS how to make a DMG file?
     
  3. Unwanted_Satellite

    Unwanted_Satellite Member

    Joined:
    Oct 6, 2018
    Posts:
    5
    Just want to bump this and also confirm that moving it out of the folder after extraction worked for me.
     
    Samuel Venable likes this.
  4. Pawel

    Pawel Member

    Joined:
    Nov 29, 2016
    Posts:
    21
    I have the same issue.
    Samuel method works but it is not ideal solution when I have to explain every customer what they should do.

    I have tried dmg solution but it does't work for me...

    Have anyone found a permanent solution? YoYo Games?
     
  5. Flaick

    Flaick Member

    Joined:
    Feb 3, 2019
    Posts:
    86
    i've solved removing blank space from Display Name into macOS settings window.

    upload_2019-7-12_14-43-12.png
     
  6. flykidsblue1

    flykidsblue1 Member

    Joined:
    Jul 6, 2017
    Posts:
    43
    I tried that but it didn't work, still gives me the same error. Are yoyo games ever going to fix this error? It's been going for pretty much years now. I've seen other forums that have had the same error since GM 1.4
     
  7. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    5,043
    Have you tried cleaning the cache since making the name change?
    Have you also tried resaving your project via File > Save As to remove spaces and any none standard characters from the project name?

    If it still doesn't work use Help > Report a Bug in the IDE and follow the steps, attaching a small project that shows the error if possible.
     
  8. IndianaBones

    IndianaBones Member

    Joined:
    Jul 5, 2016
    Posts:
    2,398
    It's usually not an error. As soon as you download something, Mac Gatekeeper flags it as quarantined if it hasn't been code signed, preventing it from being run accidentally as a security feature. This is not Yoyo's responsibility in this case.
     

Share This Page