Mac OSX "Unable to find game!!" after compiling, uploading and redownloading...

Discussion in 'Legacy GameMaker Community Tech Support' started by Omlette, May 15, 2017.

Tags:
  1. Omlette

    Omlette Member

    Joined:
    Aug 17, 2016
    Posts:
    12
    Hi everyone.

    I'm currently trying to distribute my game for MacOSX. I'm using Sierra (10.12) and GM:S 1.99.525 EA.
    I'm running the project TO Xcode, and I've made sure to disable the "Build for Mac App Store check box" as well as keep the "Signing Identity" text box empty.

    When I launch the release build .app that was compiled by Xcode, the .app works.

    Now, after I upload that same file to itch, redownload it through chrome, and double click it -- I get the "Unable to find game!!" error.

    When I move the downloaded .app to a different directory and launch it, the .app works.
    When I copy and paste the same .app into the same directory, it works.
    When I launch the original "Unable to find game!!" through bash using "open -a", it works.

    However, it doesn't work when I double click it regularly after downloading it through chrome.

    Now, here's something else that's very interesting:
    If you do make a copy of the bugged copy to "fix" it (so you have 1 bugged copy and 1 fixed copy), empty out the bugged .app (ie. Delete the "Contents" directory) and copy the Contents directory from the WORKING .app to the buggy app, I still get the same error.


    Apparently Nuclear Throne had a similar issue in the past where the cause of this was the fact that there was a space character somewhere in the project but I've went through all the strings that I can access through both GM:S and Xcode and I found no space character in the path or anything...
    http://steamcommunity.com/app/242680/discussions/0/540739405594642068/

    Here's the game that I'm trying to fix it for: https://omrii.itch.io/shhttpsitchiojamagdg-demo-day-14

    For the ADMINS, this is the most relevant article I found on the website, but it doesn't address this specific problem... https://help.yoyogames.com/hc/en-us...gest=73ddee85118d48ee99d3c14f611caa0cb309a54c

    Not quite sure what to do and I'm stumped.
    If you'd like me to check any of my steps, upload photos of my settings pages or WHATEVER because I left anything out, let me know.

    Any help would be appreciated!
     
    Last edited: May 15, 2017
    Petr Skornok and SavvyDev06 like this.
  2. Omlette

    Omlette Member

    Joined:
    Aug 17, 2016
    Posts:
    12
    bump!
     
  3. Dennis Lenz

    Dennis Lenz Member

    Joined:
    Jul 9, 2016
    Posts:
    38
    Discovered the same today. Compiled my App for OSX, tried it on an Macbook using El Capitain - works fine. Send the generated App.zip to a friend using OSX Sierra - "Unable to find game!!".
    Using Steam Gamemaker Studio v1.99.548 here ...
     
    SavvyDev06 likes this.
  4. Artiph

    Artiph Member

    Joined:
    Apr 8, 2017
    Posts:
    8
    This is... oddly EXACTLY the same situation I'm in, except I'm using the non-Steam version of GMS2.

    Anyone happen to have any idea what the deal is?
     
    SavvyDev06 and Soilworker like this.
  5. Soilworker

    Soilworker Member

    Joined:
    Jul 19, 2017
    Posts:
    3
    Same. My alpha game has a single room and almost nothing going on yet, extremely clean config as I've just started using GMS2 with no prior GMS experience (but lots of programming experience including C++ and C#/Unity.) My build is working perfectly on Windows, and perfectly on my development Mac, but as soon as I take the .zip to another Mac, it gets this error.

    I tried the older workaround of copying the .app to another folder, but this results in a game that crashes on launch (segmentation fault) - so the behavior _is_ changed simply by copying. In that case, it says it's unable to find playerachievementcache.dat - which to my understanding is a Steam related file. I don't have Steam enabled in my builds, though...

    Any help would be appreciated. I realize most of the market is Windows (my primary platform), but it's important to me that my game work on all 3 platforms (Windows, Mac, Linux) as I have testers running all 3.
     
    Last edited: Jul 19, 2017
    SavvyDev06 likes this.
  6. joefrizzell

    joefrizzell Member

    Joined:
    Mar 11, 2017
    Posts:
    1
    Sorry for pinging an old post, but I was having this issue too and apparently it has something to do with the compression that gamemaker uses to make the zip the app up. To fix this I took the working file and added it to a dmg instead of using the built in zip functionality. You can't open the game while its still in the dmg, but if you copy it out it works.
     
    Nyarlathotep and SavvyDev06 like this.
  7. Soilworker

    Soilworker Member

    Joined:
    Jul 19, 2017
    Posts:
    3
    Very interesting! I can't believe I didn't think to try that. Must be that the zip routine is corrupting permissions inside the bundle somewhere (my guess anyway.) Thanks!!!
     
  8. bml

    bml Member

    Joined:
    Mar 13, 2017
    Posts:
    29
    It's related to the extended attributes which can cause it to be quarantined:

    blomelan$ ls -l
    drwxr-xr-x@ 3 blomelan 101 102 Aug 30 22:20 Dungeon-1.app (no game error)
    drwxr-xr-x 3 blomelan 101 102 Aug 30 22:20 Dungeon.app (works)

    blomelan$ xattr -l *
    Dungeon-1.app: com.apple.quarantine: 00e2;00000000;The\x20Unarchiver;

    blomelan$ xattr -d com.apple.quarantine Dungeon-1.app/ (clears extended attributes)
     
  9. SeanGMC

    SeanGMC Member

    Joined:
    Apr 9, 2017
    Posts:
    9
    How do you do this?
     
  10. SeanGMC

    SeanGMC Member

    Joined:
    Apr 9, 2017
    Posts:
    9
    How are you able to fix this problem?
     
  11. Ouren

    Ouren Member

    Joined:
    Jan 10, 2017
    Posts:
    9
    Last edited: Feb 16, 2018
  12. Omlette

    Omlette Member

    Joined:
    Aug 17, 2016
    Posts:
    12
    I already included that in the OP lol.
    The solution I found at the time is to just put your game in whatever MacOS's zip files are (.dmg)
    (credit to joefrizzell who posted this answer above lol)
     
    Last edited: Feb 16, 2018
  13. mudora55

    mudora55 Member

    Joined:
    Dec 23, 2016
    Posts:
    30
    Time is 2099, same issue is still found in the newest version. Over.

    ps. the (.dmg) method works here
     
  14. dannyjenn

    dannyjenn Member

    Joined:
    Jul 29, 2017
    Posts:
    566
    Has this ever been fixed? I'm having the same problem.
    IDE Version: 2.2.1.375
    Current Runtime: 2.2.1.287

    (The DMG method works.)

    edit - Sorry, I didn't realize this thread was in the Legacy forum. I'm using the latest version. Maybe I should start a new thread in the GMS2 forum?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice