• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Mac OSX unable to build mac OS

babyjeans

Member
I've been trying to build a mac OS version of my GMSJam / LudumDare 37 game, but I can't seem to get it to sign the code properly. I AM using the VM build since I saw we have code signing issues with YYC.

I'm not so sure it's a bug in GMS2 more than its a lack of know how with this... but I've got my Mac Developer Relations Certificate, and I've created a Developer ID Application Certificate. I created a Distribution Provisioning Profile, and I've got an App ID for the game, tied to the provision and the Developer ID. I noticed today's update has a field for the Team ID and Signature Identity now in the game options, so I've added the Team ID to both. It seems to find the appropriate Developer ID Signature Identity this way. I had errors when I tried using my name, or any other ID. I also tried removing both of these fields. I'm using my App ID in the "com.rousr.andismovingcompany" form, I didn't put the prefix as I didn't think I had to. No difference if I try that or the short name even - after it finishes building, it still crashes immediately and says Code Signature Invalid for the crash reason.

I'm out of ideas and couldn't seem to find anything through searching, any ideas? I can Report a Bug if all this sounds like I'm fine on my end. I don't know how to test I have my certificates properly setup, but as far as I can tell I do.
 
T

TalkyLemon

Guest
First things first - have you checked over the macOS setup guide here?
http://help.yoyogames.com/hc/en-us/articles/235186128-Setting-Up-For-macOS

If you have and it's still not working there are quite a few things that could be going wrong here. Your best bet is probably to Report a Bug and include the contents of your "Output" window so we can try and track down exactly what problem you're seeing. Hopefully this will get things sorted!
 

babyjeans

Member
Thanks for the reply. I hadn't seen that guide but I actually DID follow all of those steps. I submitted a bug with my output, but not sure it really says anything useful.
That link also has info about manually signing your YYC builds... does that work and the bug is just that it's not auto-doing it? Perhaps I'll give that a shot tonight and see if I can sign my own YYC build following those instructions.
 
Top