• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Linux Ubuntu Release - Game works, Achievements work, but Steam Play button doesn't

dyh

Member
Hello everyone
Somehow I managed to get my game running from my PC in the Ubuntu 18.04.2 Virtual Machine ( You can see how I did it in my last thread ).
The achievements are also activating while I'm connected to my Steam account through the app.
However I can only open the game by running the "runner" file by myself on the local steam files.
For some reason the steam "play" button in the app doesn't respond.
bug ubuntu.jpg
Should I add a special "execute.sh" file to the build? And if yes what should be its code?
I'll be very glad to get a respond, as I am so close to finally finish this build.
 

O.Stogden

Member
I am also having this problem when using an Ubuntu 20.04 system (not VM), on GMS 2.3.0, export is Ubuntu YYC.

The game runs fine if I browse the local files and run the executable directly, however if I run the game via the "play" button, it just says "Preparing to start The Race Factory" which then closes, and nothing happens.

My Steamworks setup is identical to Dyh's, except I have 'TRF' instead of 'Rewrite - DYH' as the executable.

Did you ever fix this @dyh ?

This appears to be the same setup used by Nocturne in the documentation he wrote about how to prepare your Steamworks settings. My file structure is the same as the ones seen here: https://help.yoyogames.com/hc/en-us...sing-The-Steamworks-SDK-With-GameMaker-Studio

Although that documentation is quite out of date now, it was for GMS1, I don't believe it was ever rewritten for GMS2. I assumed because the setup is identical in both.

If I rename the executable or the directory the executable is in, then Steam returns an error of 'Cannot find the game executable' which it doesn't do otherwise. So it definitely finds the executable, it just can't seem to 'execute' it.

EDIT: I fixed my problem by using these 2 posts:


Followed by:


If read and followed carefully, and using the right downloads (libcurl4 not libcurl3, make sure the file is libcurl.so.4.5.0 and not libcurl.so.4.4.0).
 
Last edited:

dyh

Member
Hi @O.Stogden
I fixed it as well by using a .sh script as the "Executable" that referred steam to the right libcurl.so.4+libsteam_api.so files ( which I placed together in my game directory ).
Good luck with your game
 

Samuel Venable

Time Killer
Does GMS 2.3 even support Ubuntu 20.04? If it does, what version? That is a nice surprise and it isn't documented yet.
 

O.Stogden

Member
Does GMS 2.3 even support Ubuntu 20.04? If it does, what version? That is a nice surprise and it isn't documented yet.
It is mentioned here: https://help.yoyogames.com/hc/en-us/articles/227860547-GMS2-Required-SDKs

But it wasn't quite where I expected to find it myself.

If you scroll down to GMS2's Supported Platforms and then to Ubuntu you find the following:

GMS2 SDK GUIDE said:
  • GMS2 2.3.1 Beta or above: Ubuntu 20.04 LTS 64bit or Ubuntu 18.04 LTS 64bit. Also have the option of building ARMv7 packages by simply targeting an ARMv7 device when you do your build.
  • GMS2 2.3.0: Ubuntu 20.04 LTS 64bit or Ubuntu 18.04 LTS 64bit.
  • GMS2 2.2.1 to 2.2.5: Ubuntu 18.04 LTS 64bit is the only distro we support.
  • GMS2 older than 2.2.1 (please update instead!): Ubuntu 16.04 LTS 64bit is the only distro we support.
For simply playing GMS2 games: Ubuntu 16 or later is required. Other distros can usually run the games GMS2 generates with no issues, but we only state support for Ubuntu, so if you have issues playing games on these other platforms you will need to investigate this yourself. All games are 64bit-only.

ARMv7 architecture support is available for games built with GMS2 2.3.1 or above if the developer built the package using an ARMv7 device.
 
Top