• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Linux Ubuntu export - steam achievements not working


Hello everyone
So I just released my game on steam for Windows PC and it works ( Game + achievements both work ).
I try now to export it for Ubuntu.
When I run it in Game maker for windows through a Linux Virtual Machine all works as well ( Game + achievements ).

BUT when I export it there are two issues:
1. The game doesn't run on the Linux Virtual Machine unless I replace the exported game.unx file with the one in the GameMakerStudio2 library
2. MOST IMPORTANT - the achievements don't work anymore. I've been trying to replace the libsteam_api.so file with others but it doesn't help.
If anybody knows how to fix this please help. I really like to have a Linux export to my game.


That is interesting that it still runs... I can no longer run through the Windows IDE to my linux virtual machine, it just gives me some ssh error (It worked perfectly fine with the last 2.2 version). I can export the build without it throwing any errors but when I update my steam depot with that built version and pull it on my linux machine through steam it doesn't even start. Definitely hope all the issues with the build to linux gets fixed since I also really like having that option.


Yeah, I just upgraded mine from 2.2 to 2.3 and now the build doesn't work anymore lol.
I'll post here if I find a solution


Ok. I got some progress. It might be working now.
I haven't yet uploaded it to steam, but the game runs now + achievements are now working!
Here is what I did.
I followed these instructions over here: https://medium.com/@Nikles/compiling-gamemaker-studio-2-games-in-ubuntu-linux-18-04-03-320607325c60
using the latest GameMaker 2.3 + Ubuntu Virtual Machine 18.04.2

Then I ran the game on the windows GameMaker through the Linux Virtual Machine when the option of enable steam is off - It worked ( Keep the files in the Virtual Machine -They are important! )
Then I ran the game on the windows GameMaker through the Linux Virtual Machine when the option of enable steam is on - It did not work

BUT during the time the program tries to build the game when the option of enable steam is on, I noticed there is a temporary folder "GameAssetsLinux.zip" being built on my PC ( directory Y in my computer ).

I copied that zip file on my PC, extracted the folder "assests" and placed it next to my game in the Ubuntu Virtual Machine ( the game that worked when the steam option was disabled).
Then I copied the sdk folder in my PC and placed it near the game that worked on my Ubuntu.
Finally pressing on the "runner" file on my Ubuntu Virtual Machine runs the game with working achievements.

Why was this so complicated, I have no idea. šŸ˜•
Anyway, the game is called "Rewrite - DYH" in case you want to check it out, hopefully it will be uploading its Ubuntu release on steam soon
Last edited: