• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Legacy GM [Tutorial] Troubleshooting a clean install of GM1.4 (studio) + modules

Introduction:
I don't think I've ever been able to make a fresh install of game maker studio without having problems. So this topic is to help my future self and anyone else that also experiences headaches with what should be a very simple task.

Part 1
This step is obsolete and will fix issues for you, but not your players. Skip to the next post.
I'm leaving the instructions here as it's still a solid guide on how to install an older version of windows 10 that I may need to refer to or move in the future.

Installing a version of windows 10 that doesn't break GM1.4
At some point, windows released an update that cripples game maker's runner. What should be 30fps looks to be more like 20, despite game maker claiming the fps real to be 1000+. This only seems to occur on newly compiled games using the updated windows.

This section covers how to install a specific version of windows that I've found works well with game maker studio 1.4.9999, and prevent it from forcing you to update. It's possible that newer versions work too. But all I know is that the current version of windows 10 (as of Sunday 14th March 2021) break things. I'd like to make it VERY CLEAR that disabling windows update comes with security issues, for example if a critical security flaw is discovered, you will never receive the patch for it. You stop updates AT YOUR OWN RISK.

If you're performing a clean install on top of your old computer, MAKE A BACKUP. Once your data is gone, it's gone. Don't take the risk.
You can get rufus here.
Set the mode to download like this:

Then press download


A form will open, with only the top option. As you select each option and press continue, another one will open. You should end up with a screen that looks like this:

(Remember to select 'download using a browser').
Then press download.

After it installs, you should have this in your downloads:
If you're going to virtualise windows using parallels or VMware, you can skip this step. The iso is all you need. But if you're going to install this directly onto a computer, you'll need to create a bootable usb drive.

Using rufus again, follow this tutorial. If the link is broken use the wayback machine, or google 'how to turn an iso file into a bootable usb'.
Download O&O shutup10, and keep it handy either on a usb stick or ready to copy to your vm.
Make sure WIFI IS DISABLED during your install, otherwise windows will attempt to install the latest version. The only time you should enable wifi at this point is to allow windows to verify the key. You can get a single use OEM key for cheap from here.
On the freshly installed windows 10, and run shutup10.

First, you'll want to make a system restore point.


Then once that's done, scroll down to windows update and make all of the switches green:


Close shutup 10, then restart your computer. Once restarted, it's safe to enable your wifi.
 
Last edited:
New updated tutorial:
Working as of 27 may 2021

Click here to download the final version of game maker studio 1.4.9999.

You can also find it by googling 'game maker release notes 1.x', clicking the top result, and then on the release notes page, click any of the green version headers to download that version.

Once downloaded, simply run the installer and follow it through.
You will need your license / login details, possibly multiple times for the steps below so keep them handy.

Had an error during the install? See the next section.
I think this error has happened to me almost every single time I've tried to reinstall game maker.

EDIT! See new post below!!

This is a game maker server issue. Either wait a few days for it to be back, or contact the help desk.

It's caused by your license having additional modules attached to it. These modules are not included in the installer, and when you validate your license, the IDE is informed that it has missing components and must download them. However the file server never responds. If you have another license that has no modules attached, try using that and it might work.

If it just is not coming back, it's possible to manually install game maker using the configuration from a previous install. This is extremely fiddly and time consuming but you will need a computer with an existing copy of game maker on.

Looking through the locations in this tutorial, look on your other computer with working game maker, and copy the information to the new one exactly. So every registry entry letter for letter, and all the files in both /local/ folders. After done, when booting game maker, make sure your wifi is disabled or it will constantly try to update itself (and get stuck). You can enable wifi again once a project is loaded.

Related topics:
This occurs because windows updates are being blocked. This can occur if you used the tutorial above on installing a specific windows version and then disabling updates.

NOTE: On a second attempt, the below method failed me, and I ended up having to go back into O&OShutup10 to re-enable Windows Update just so the installer could run. Make sure to be quick so an update doesn't sneak in while you do it and disable wifi as soon as the installer is no longer "downloading"!

First, download this. Then, open notepad and paste this in:
Code:
@echo off
Title .NET Framework 3.5 Offline Installer
for %%I in (D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist "%%I:\\sources\install.wim" set setupdrv=%%I
if defined setupdrv (
echo Found drive %setupdrv%
echo Installing .NET Framework 3.5...
Dism /online /enable-feature /featurename:NetFX3 /All /Source:%setupdrv%:\sources\sxs /LimitAccess
echo.
echo .NET Framework 3.5 should be installed
echo.
) else (
echo No installation media found!
echo Insert DVD or USB flash drive and run this file once again.
echo.
)
pause
Save it as whatever.txt.
Then open an explorer window, set the top tab to view:

And enable 'file name extensions'.

Once you've done that, rename whatever.txt to whatever.cmd.
Then right click it, and run it as administrator. It will install.

The above code is from here, and worked for me.

Other issues? Comment below.
First, you'll need to make a steamworks partner account, and go through their whole set up process. You'll also need to have bought an app token. Once that's done, make sure you're signed in, and then click here to download the FINAL recommended compatible sdk that works with studio 1.4.

Once downloaded, decompress it and put it somewhere safe. Then go into game maker's preferences:


Scroll the tabs to steam:


Then set it to that folder


And if the built in functions don't cover your needs, there's always this:

An extended library that takes better advantage of the steam api that works for GM1.4 too.
To avoid "Batch file not found at visual studio path", you'll want to download these. Install them, making sure to check all extra options in the installer.
Then you'll want to set the paths like I did in this topic.
Finally, make sure you install this (dxwebsetup.exe) to prevent this error when trying to use a shader:
Code:
ERROR!!! :: ############################################################################################

FATAL ERROR in Vertex Shader compilation

ShaderName:

D3DXCompile failed - result

############################################################################################
--------------------------------------------------------------------------------------------
called from -
If that doesn't work, you can also try looking for directx_Jun2010_redist.exe and installing that.

If using YYC for the first time in your project gives you compile errors, remember to clean your asset cache.
When you purchase spine, you'll get an email with a download link for the latest version. Once installed, on the launch screen you'll have the option to switch to the last version that works with game maker studio. The version you want is 3.4.02. Then just press start.
Unfortunately, game maker 1.4 can no longer compile games that comply with the google play's store. However it's presumably still possible to export an .apk that you can place on your phone manually or distribute via your own website.

Alternatively, you could rely on GM2's compatability scripts, and only use GM2 to import, and compile while still developing your project in studio. This sounds unstable but possible.

This link may be useful to you.

Related topics:
This doesn't seem to be working anymore, the game maker runner just freezes and crashes now. See note at the end of this section

Go into sharing settings on your mac:


Then enable file sharing and remote login. Make note of the 'computer name' here.


You'll also want to know the user/password of your computer. If you're not sure what they are, they can be found in here:


In the mac preferences in game maker, set the mac host name to the name in the sharing settings of your mac.
Set the Username to the name in the user settings of your mac
and the password is the password you use to sign into that account on the mac.

Once done, just press check mac connection.

IMPORTANT:
1. Turn remote login and sharing settings off when you're not using them. Especially if you have a weak password for your mac.
2. The compiler output will share your mac password in PLAINTEXT. Be careful if you upload it to forums when asking for help. Make sure you go through and remove it. (Definitely use ctrl-f).


Xcode
Sadly xcode 9.3 isn't supported by big sur, but you can could install Sierra on a virtual machine very easily. To do that, you can install Sierra from here.
If you're using a virtual machine, install xcode 9.2 because 9.3 doesn't work on the base Sierra install, and there doesn't seem to be a way to update it.

You can find all releases of xcode here.
You will need to sign in with your developer account for this to work.

WARNING:
This method is not working for me. If you enable 'surpress build and run' in the screenshot above, you can at least debug from the mac side. In xcode, if you press here:

and set it to the other option, the button will not be grey anymore. However when you compile, for me at least there are 20 or so red error messages. But at least you can work from there. It could be that the licenses are not up to date in my project global game settings > mac. But I don't have an active apple dev account atm so I have no way to check that. This is as far as I can take you. Have a look at these articles.

For other modules, refer to this article. If you have instructions for how to set up the rest, or you've found a useful article that helped you, comment below!
As game maker 1.4 is quite old, there are some things that don't work anymore and need to be fixed.

Microsoft changed the way sleep margins work by default for all apps, and it causes all GM1.4 compiled games to run at 66% speed. See Windows 10 Scheduler slowdown bug.

Download and import this GMS extension to your project (drag the gmez over your project, or right click the extensions folder in the resource tree and select "add extension").
Full documentation here.

To use, just call this at the start of your game.
gmsched_init();
scheduler_resolution_set(scheduler_resolution_get_min());


You can also fix already compiled games by placing this DLL next to the .exe.
But if the game uses the self extractor, i.e. they selected "Single runtime executable (.exe)" when the game was initially compiled, you must extract out all the files from the exe first. This can be done using software winrar or z7ip.

An alternative to using the extension would be to write code that counts how many times a second the game is running (don't use the fps variable, because it just returns what the fps should be), and if it doesn't match the intended fps, set the room_speed to be 33% bigger (room_speed *=1.33). This little hack does the trick for 30fps but you'll need to test it yourself for sure.
Remember, the performance issues will only occur on up to date windows 10 machines. So your code will have to activate this "speed boost" only when it's needed.

I used this method before I came across the extension.
You need to install dxwebsetup.exe (this).
If your game uses networking functions, by default, anyone can cause it to crash by sending a packet of size 0 to it.

To fix this, download and import this free GMS extension to your project (drag the gmez over your project, or right click the extensions folder in the resource tree and select "add extension").

To use, just call this at the start of your game.
buffer_create_fix();
The url_open function of GM1.4 is no longer working (not to be confused with http_get. http_get connects through code, whereas url_open physically opens your browser).
But you can fix it with this free extension!

1. Download the gmez file and import it to your project (drag it over your project, or right click the extensions folder in the resource tree and select "add extension").
2.
Code:
///url_open_fixed(url)
/*
url_open is now broken in GM1.4
So this script uses YellowAfterlife's extension to open a URL in a browser.
More info: https://yal.cc/gamemaker-fixing-22https/
*/

// Argument
var _url = argument0;

// Begin writing in a file called "shortcut.url" in our game's folder
var _path = game_save_id + "/shortcut.url";
var _txt = file_text_open_write(_path);

// Generate a file with the following text inside:
file_text_write_string(_txt,

/* Put an @ here if using GM2 --> */    /* <--*/
'[{000214A0-0000-0000-C000-000000000046}]
Prop3=19,11
[InternetShortcut]
IDList=
URL=' + _url);

// Save the file
file_text_close(_txt);

// Open the file
execute_shell_simple(_path);
And that's it! For now!
 
Last edited:
How to fix:

Screenshot 2021-05-26 at 3.35.33 pm.pngItWontLoad.gif1622068346309.png

You are not alone with this issue:


This would not have been possible without
@emmyarty
Source

Automated method:
Step 1:
Make sure you're at this point where this error occurs.
This requires you to have installed game maker fully, entered your license and restarted.
You also need to set the update channel to be "beta", not "stable" which will appear on a prompt at some point during the installation that leads to this error.
If game maker is open, you should also be able to set this through the system tray.

Step 2:
Open Notepad.exe and paste in this code:
Code:
@ECHO OFF
SET T=GAMEMAKER STUDIO 1.4 UPDATER PATCH (UNOFFICIAL 25/05/2021)
SET Q="
SET I=SUCCESSFULLY INSTALLED
SET R=SUCCESSFULLY REMOVED
SET S=
SET INPA=GameMaker-Studio
SET PTCH=patch.xml
SET CONF=GameMaker-Studio.exe.config
SET BKUP=GameMaker-Studio.exe.config.original
SET "XML=^<?xml version="1.0" encoding="utf-8"?^>^<rss xmlns:sparkle="http://www.andymatuschak.org/xml-namespaces/sparkle" xmlns:dc="http://purl.org/dc/elements/1.1/" version="2.0"^>^<channel^>^<title^>GameMaker:Studio Changelog^</title^>^<link^>patch.xml^</link^>^<description^>Most recent changes with links to updates.^</description^>^<language^>en^</language^>^<item^>^<title^>Version 1.4.9999^</title^>^<pubDate^>Thu, 04 Oct 2018 12:22:21 Z^</pubDate^>^<sparkle:releaseNotesLink^>http://www.yoyogames.com/downloads/gm-studio/release-notes-studio.html^</sparkle:releaseNotesLink^>^<enclosure url="https://gminstall.yoyogames.com/gm-studio/Original-1.4.9999.zip" sparkle:version="1.4.9999" type="application/octet-stream" length="81264342" sparkle:dsaSignature="MCwCFDaE2BeHg+EML8gYyzd8Xy4IdTPyAhQ4yaJrdsgpXXNgPZZ64xJR9OzleA=="^>^<module name="AmazonFire" url="https://gminstall.yoyogames.com/gm-studio/9f5c03ec-4a64-4546-b410-5376239101f0.zip" sparkle:version="1.4.9999" length="5069151" sparkle:dsaSignature="MCwCFFpBn9bgdMCIQTXLVPuTGV1KD1yzAhQUlDoSITGyIIr9fp9IaVhW43lFeQ=="/^>^<module name="Android" url="https://gminstall.yoyogames.com/gm-studio/7d94eaf4-70c6-4b2d-8e69-3b7ff02b4c0c.zip" sparkle:version="1.4.9999" length="25305856" sparkle:dsaSignature="MC0CFHIbL2vKyCf5OnMqfjRXQrksx4eWAhUAk8bZWnd/JmUsoOkhmszXCCVG5J4="/^>^<module name="AndroidTV" url="https://gminstall.yoyogames.com/gm-studio/a81f5d87-910a-481d-b9c5-073729cadefb.zip" sparkle:version="1.4.9999" length="95173" sparkle:dsaSignature="MC0CFFYuZFLxOf/mLnYsKu64jw6AbqzpAhUAiyD+dx2FLlke4f7j9bkVzo3wug4="/^>^<module name="AppleTV" url="https://gminstall.yoyogames.com/gm-studio/eb86674d-fe3f-481b-a5b0-b7534d96f94c.zip" sparkle:version="1.4.9999" length="421360" sparkle:dsaSignature="MC0CFQCTY3jlegzmcdADG0eaZEWJpkgobQIUKNLJ9a/YSG4vE4wOsFxApGehizM="/^>^<module name="HTML5" url="https://gminstall.yoyogames.com/gm-studio/a45f6374-8587-47f4-a043-e0d0c830d941.zip" sparkle:version="1.4.9999" length="28498" sparkle:dsaSignature="MC0CFQCIzB3RMZ8/M6KwgLVo45Yd4JwCWgIUS+/b15nOFMdDevTV6BunyLonFy8="/^>^<module name="iOS" url="https://gminstall.yoyogames.com/gm-studio/ce946ba0-f562-4e56-9df1-fc184aebacfe.zip" sparkle:version="1.4.9999" length="78935051" sparkle:dsaSignature="MC4CFQCIlGYw0AvsUDJiIsfSbbS2QiGMNgIVAICa3fa+B4YGfd3bG7Wb/pLy4n2N"/^>^<module name="Linux" url="https://gminstall.yoyogames.com/gm-studio/6aabb516-7b23-4277-ad8d-e9df33d4f77c.zip" sparkle:version="1.4.9999" length="12411693" sparkle:dsaSignature="MCwCFEmmCYJ0H9EmF29LI4QyjYiTo7bQAhRHoUJcjMcc+HDGugxuvo+mmIBEUw=="/^>^<module name="Mac" url="https://gminstall.yoyogames.com/gm-studio/55a7c0e7-fd96-45ae-971d-31164ec69b9e.zip" sparkle:version="1.4.9999" length="34471534" sparkle:dsaSignature="MCwCFG6UxBEN8k4BWgsQ1IXzC9MhCTLAAhQjWzDnfVsDxHHh64BFfmWl30XTsA=="/^>^<module name="Pro" url="https://gminstall.yoyogames.com/gm-studio/d7ebbb34-ee04-41b0-9d43-a751fd5c77e8.zip" sparkle:version="1.4.9999" length="92568780" sparkle:dsaSignature="MCwCFBy0E9rNynfMY6Sp5C9Lo8MaTM7EAhRV7mqYdVD4wPa9jqCEYxcOamYHlw=="/^>^<module name="PS3" url="https://gminstall.yoyogames.com/gm-studio/a106b85f-0ea3-4db7-8ba3-a691eb0eca5e.zip" sparkle:version="1.4.9999" length="14539872" sparkle:dsaSignature="MC4CFQCY5kY5oHKd5rdGRPiGStK/EXP4GQIVAJqrju0czlgOsBXezh2A+mPWOg7D"/^>^<module name="PS4" url="https://gminstall.yoyogames.com/gm-studio/deec894e-fac6-498e-bcaa-cd37147870c0.zip" sparkle:version="1.4.9999" length="10871558" sparkle:dsaSignature="MCwCFGHbd8v+0WKpWh+mJZwtRcCK6MCzAhRPy8Br5hN4ZH3xVg7Px+aRR8iXlQ=="/^>^<module name="PSVita" url="https://gminstall.yoyogames.com/gm-studio/7d139c1b-5222-4d9f-b6ec-5b30ebec2452.zip" sparkle:version="1.4.9999" length="9690503" sparkle:dsaSignature="MCwCFBnoEn7eGBtp+ClNzEijB1/wDyKuAhRFUNbbgZSOzHs6LnGKWSx466BEaw=="/^>^<module name="Tizen" url="https://gminstall.yoyogames.com/gm-studio/f79b442a-4950-4faf-8748-e057ac9da8b6.zip" sparkle:version="1.4.9999" length="32458" sparkle:dsaSignature="MCwCFGselJ95poGR1hRLuHPvxIMPSPXvAhQMm3PqQKZ9VS5e0TcWZ66a0JtX8Q=="/^>^<module name="Windows8" url="https://gminstall.yoyogames.com/gm-studio/9f6adea6-043a-42af-bc6b-71e65756a22d.zip" sparkle:version="1.4.9999" length="9516014" sparkle:dsaSignature="MCwCFHf3c6Msp1j5MJXNsuIqsM39jCOxAhQWXAjWMJftJXrBvp8bTORKPOq1nQ=="/^>^<module name="WindowsPhone" url="https://gminstall.yoyogames.com/gm-studio/736665c7-2191-44d8-9d4f-de3cf88df1fa.zip" sparkle:version="1.4.9999" length="8504996" sparkle:dsaSignature="MCwCFGUwUu9FQ6rpaO51pg7QcuIcDciaAhQRrvA1Ilbu6vfEyZEmbdD9xBp5JA=="/^>^<module name="WindowsUAP" url="https://gminstall.yoyogames.com/gm-studio/0d296f94-ebd6-458f-b2c9-bbcca6241b94.zip" sparkle:version="1.4.9999" length="36675401" sparkle:dsaSignature="MCwCFCOXJhbb038HSYWtsqZ8knQ8ihjTAhQgV7DyK/VD55Hl1uplK+57pA+U7g=="/^>^<module name="XBoxOne" url="https://gminstall.yoyogames.com/gm-studio/6420318d-2576-4e30-a47b-b9ffb720ab94.zip" sparkle:version="1.4.9999" length="31969457" sparkle:dsaSignature="MC0CFQCJzkRw0ckzRTKxmKV3ROQ2SkZzcwIUR6jBHRG0JUaJapOT+x3sUuWEOl8="/^>^</enclosure^>^</item^>^</channel^>^</rss^>"
SET "SEC1=^<?xml version="1.0"?^> ^<configuration^> ^<configSections^> ^<sectionGroup name="userSettings" type="System.Configuration.UserSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"^> ^<section name="Updater.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" allowExeDefinition="MachineToLocalUser" requirePermission="false" /^> ^</sectionGroup^> ^</configSections^> ^<appSettings^> ^<add key="Sparkle.SUFeedURL" value="file:///"
SET "SEC2= /^>^<add key="Sparkle.SUStableFeedURL" value="file:///"
SET "SEC3= /^> ^<add key="YYRegKey" value="Software\GMStudio" /^> ^<add key="ExeName" value="5piceIDE.exe" /^> ^<add key="ProductName" value="GameMaker-Studio" /^> ^<add key="ClientSettingsProvider.ServiceUri" value="" /^> ^</appSettings^> ^<userSettings^> ^<Updater.Properties.Settings^> ^<setting name="LastSkipVersion" serializeAs="String"^> ^<value^>8.1.0^</value^> ^</setting^> ^<setting name="LastCheck" serializeAs="String"^> ^<value /^> ^</setting^> ^<setting name="AutomaticallyInstall" serializeAs="String"^> ^<value^>False^</value^> ^</setting^> ^<setting name="UpdateChannel" serializeAs="String"^> ^<value^>-1^</value^> ^</setting^> ^<setting name="YYCheckDate" serializeAs="String"^> ^<value /^> ^</setting^> ^</Updater.Properties.Settings^> ^</userSettings^> ^<startup^> ^<supportedRuntime version="v2.0.50727" /^> ^</startup^> ^<system.web^> ^<membership defaultProvider="ClientAuthenticationMembershipProvider"^> ^<providers^> ^<add name="ClientAuthenticationMembershipProvider" type="System.Web.ClientServices.Providers.ClientFormsAuthenticationMembershipProvider, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" serviceUri="" /^> ^</providers^> ^</membership^> ^<roleManager defaultProvider="ClientRoleProvider" enabled="true"^> ^<providers^> ^<add name="ClientRoleProvider" type="System.Web.ClientServices.Providers.ClientRoleProvider, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" serviceUri="" cacheTimeout="86400" /^> ^</providers^> ^</roleManager^> ^</system.web^> ^</configuration^>"
SET POINTER=%APPDATA%\%INPA%\%PTCH%
SET "POINTER=%POINTER:\=/%"
COLOR 97
CLS
ECHO %T%
ECHO.
ECHO.
IF EXIST %APPDATA%\%INPA%\%CONF% GOTO MENU
ECHO FAILED TO DETECT ATOM INSTALLATION AT %LOCALAPPDATA%\%INPA%
ECHO.
ECHO ABORTING SETUP
ECHO.
PAUSE
GOTO END

:MENU
ECHO %S%(INSTALLATION DETECTED AT %LOCALAPPDATA%\%INPA%)
ECHO.
ECHO %S%...........................................................
ECHO %S%Type 1, 2, or 0 to select option and then ENTER to confirm
ECHO %S%...........................................................
ECHO.
IF NOT EXIST %APPDATA%\%INPA%\%BKUP% ECHO %S%1 - Install Patch
IF EXIST %APPDATA%\%INPA%\%BKUP% ECHO %S%1 - (Re)install Patch
IF EXIST %APPDATA%\%INPA%\%BKUP% ECHO %S%2 - Remove Patch
IF NOT EXIST %APPDATA%\%INPA%\%BKUP% ECHO %S%2 - Remove Patch (Clean-up Only)
ECHO %S%0 - EXIT
ECHO.
ECHO.
SET /P M="ENTER CHOICE:  "
IF %M%==1 GOTO INSTALL
IF %M%==2 GOTO UNINSTALL
IF %M%==0 GOTO END

:INSTALL
CLS
ECHO %T%
IF NOT EXIST %APPDATA%\%BKUP% REN %APPDATA%\%INPA%\%CONF% %BKUP%
ECHO %S%Backup Successful / Already Exists
IF EXIST %APPDATA%\%INPA%\%PTCH% ECHO %S%Patch File Already Exists, Will Be Replaced
IF EXIST %APPDATA%\%INPA%\%PTCH% DEL %APPDATA%\%INPA%\%PTCH%
ECHO %XML% 1>%APPDATA%\%INPA%\%PTCH% 2>NUL
ECHO %S%Patch File Saved: %APPDATA%\%INPA%\%PTCH%
IF EXIST %APPDATA%\%INPA%\%BKUP% DEL %APPDATA%\%INPA%\%CONF% 2>NUL
ECHO %SEC1%%POINTER%%Q%%SEC2%%POINTER%%Q%%SEC3% 1>%APPDATA%\%INPA%\%CONF% 2>NUL
ECHO %S%Configuration File Patched: %APPDATA%\%INPA%\%CONF%
ECHO %S%%I%
ECHO.
PAUSE
CLS
ECHO %T%
ECHO %S%%I%
ECHO.
GOTO MENU

:UNINSTALL
CLS
ECHO %T%
IF EXIST %APPDATA%\%INPA%\%BKUP% DEL %APPDATA%\%INPA%\%CONF% 2>NUL
IF EXIST %APPDATA%\%INPA%\%PTCH% DEL %APPDATA%\%INPA%\%PTCH% 2>NUL
REN %APPDATA%\%INPA%\%BKUP% %CONF%
ECHO %S%%R%
ECHO.
PAUSE
CLS
ECHO %T%
ECHO %S%%I%
ECHO.
GOTO MENU

:END
Huge thanks to @emmyarty for writing this code.

Step 3:
Save the file to the desktop as "ModulePatcher.cmd". The format should be UTF-8. And make sure it's saved as .cmd and not .txt.cmd.
If you've done it right, it should be a white box with some cogs in, not a piece of paper.

Step 4:
Right click it and then select "run as administrator".

You should get a screen like this:
1622067789717.png

If it says FAILED TO DETECT ATOM INSTALLATION AT <path>
It means that game maker has not been unpackaged yet or is not even installed. To fix, run game maker (or install it at all).

Step 5:
Press 1, then enter.
It should now say SUCCESSFULLY INSTALLED.

Step 6:
Run game maker again. It should work.


If you still get this error:
1622068346309.png
Try the manual method. On one occasion that I haven't been able to reproduce, the batch.xml file wasn't created and I'm not sure why. Perhaps differences in batch files between windows versions. Whatever the cause, hopefully you will spot where the problem is while doing the manual method!

Manual method
Step 1:
Make sure you're at this point where this error occurs.
This requires you to have installed game maker fully, entered your license and restarted.
You also need to set the update channel to be "beta", not "stable" which will appear on a prompt at some point during the installation that leads to this error.
If game maker is open, you should also be able to set this through the system tray.

Step 2:
Open notepad and paste in this:
Code:
<?xml version="1.0" encoding="utf-8"?><rss xmlns:sparkle="http://www.andymatuschak.org/xml-namespaces/sparkle" xmlns:dc="http://purl.org/dc/elements/1.1/" version="2.0"><channel><title>GameMaker:Studio Changelog</title><link>patch.xml</link><description>Most recent changes with links to updates.</description><language>en</language><item><title>Version 1.4.9999</title><pubDate>Thu, 04 Oct 2018 12:22:21 Z</pubDate><sparkle:releaseNotesLink>http://www.yoyogames.com/downloads/gm-studio/release-notes-studio.html/sparkle:releaseNotesLink<enclosure url="https://gminstall.yoyogames.com/gm-studio/Original-1.4.9999.zip" sparkle:version="1.4.9999" type="application/octet-stream" length="81264342" sparkle:dsaSignature="MCwCFDaE2BeHg+EML8gYyzd8Xy4IdTPyAhQ4yaJrdsgpXXNgPZZ64xJR9OzleA=="><module name="AmazonFire" url="https://gminstall.yoyogames.com/gm-studio/9f5c03ec-4a64-4546-b410-5376239101f0.zip" sparkle:version="1.4.9999" length="5069151" sparkle:dsaSignature="MCwCFFpBn9bgdMCIQTXLVPuTGV1KD1yzAhQUlDoSITGyIIr9fp9IaVhW43lFeQ=="/><module name="Android" url="https://gminstall.yoyogames.com/gm-studio/7d94eaf4-70c6-4b2d-8e69-3b7ff02b4c0c.zip" sparkle:version="1.4.9999" length="25305856" sparkle:dsaSignature="MC0CFHIbL2vKyCf5OnMqfjRXQrksx4eWAhUAk8bZWnd/JmUsoOkhmszXCCVG5J4="/><module name="AndroidTV" url="https://gminstall.yoyogames.com/gm-studio/a81f5d87-910a-481d-b9c5-073729cadefb.zip" sparkle:version="1.4.9999" length="95173" sparkle:dsaSignature="MC0CFFYuZFLxOf/mLnYsKu64jw6AbqzpAhUAiyD+dx2FLlke4f7j9bkVzo3wug4="/><module name="AppleTV" url="https://gminstall.yoyogames.com/gm-studio/eb86674d-fe3f-481b-a5b0-b7534d96f94c.zip" sparkle:version="1.4.9999" length="421360" sparkle:dsaSignature="MC0CFQCTY3jlegzmcdADG0eaZEWJpkgobQIUKNLJ9a/YSG4vE4wOsFxApGehizM="/><module name="HTML5" url="https://gminstall.yoyogames.com/gm-studio/a45f6374-8587-47f4-a043-e0d0c830d941.zip" sparkle:version="1.4.9999" length="28498" sparkle:dsaSignature="MC0CFQCIzB3RMZ8/M6KwgLVo45Yd4JwCWgIUS+/b15nOFMdDevTV6BunyLonFy8="/><module name="iOS" url="https://gminstall.yoyogames.com/gm-studio/ce946ba0-f562-4e56-9df1-fc184aebacfe.zip" sparkle:version="1.4.9999" length="78935051" sparkle:dsaSignature="MC4CFQCIlGYw0AvsUDJiIsfSbbS2QiGMNgIVAICa3fa+B4YGfd3bG7Wb/pLy4n2N"/><module name="Linux" url="https://gminstall.yoyogames.com/gm-studio/6aabb516-7b23-4277-ad8d-e9df33d4f77c.zip" sparkle:version="1.4.9999" length="12411693" sparkle:dsaSignature="MCwCFEmmCYJ0H9EmF29LI4QyjYiTo7bQAhRHoUJcjMcc+HDGugxuvo+mmIBEUw=="/><module name="Mac" url="https://gminstall.yoyogames.com/gm-studio/55a7c0e7-fd96-45ae-971d-31164ec69b9e.zip" sparkle:version="1.4.9999" length="34471534" sparkle:dsaSignature="MCwCFG6UxBEN8k4BWgsQ1IXzC9MhCTLAAhQjWzDnfVsDxHHh64BFfmWl30XTsA=="/><module name="Pro" url="https://gminstall.yoyogames.com/gm-studio/d7ebbb34-ee04-41b0-9d43-a751fd5c77e8.zip" sparkle:version="1.4.9999" length="92568780" sparkle:dsaSignature="MCwCFBy0E9rNynfMY6Sp5C9Lo8MaTM7EAhRV7mqYdVD4wPa9jqCEYxcOamYHlw=="/><module name="PS3" url="https://gminstall.yoyogames.com/gm-studio/a106b85f-0ea3-4db7-8ba3-a691eb0eca5e.zip" sparkle:version="1.4.9999" length="14539872" sparkle:dsaSignature="MC4CFQCY5kY5oHKd5rdGRPiGStK/EXP4GQIVAJqrju0czlgOsBXezh2A+mPWOg7D"/><module name="PS4" url="https://gminstall.yoyogames.com/gm-studio/deec894e-fac6-498e-bcaa-cd37147870c0.zip" sparkle:version="1.4.9999" length="10871558" sparkle:dsaSignature="MCwCFGHbd8v+0WKpWh+mJZwtRcCK6MCzAhRPy8Br5hN4ZH3xVg7Px+aRR8iXlQ=="/><module name="PSVita" url="https://gminstall.yoyogames.com/gm-studio/7d139c1b-5222-4d9f-b6ec-5b30ebec2452.zip" sparkle:version="1.4.9999" length="9690503" sparkle:dsaSignature="MCwCFBnoEn7eGBtp+ClNzEijB1/wDyKuAhRFUNbbgZSOzHs6LnGKWSx466BEaw=="/><module name="Tizen" url="https://gminstall.yoyogames.com/gm-studio/f79b442a-4950-4faf-8748-e057ac9da8b6.zip" sparkle:version="1.4.9999" length="32458" sparkle:dsaSignature="MCwCFGselJ95poGR1hRLuHPvxIMPSPXvAhQMm3PqQKZ9VS5e0TcWZ66a0JtX8Q=="/><module name="Windows8" url="https://gminstall.yoyogames.com/gm-studio/9f6adea6-043a-42af-bc6b-71e65756a22d.zip" sparkle:version="1.4.9999" length="9516014" sparkle:dsaSignature="MCwCFHf3c6Msp1j5MJXNsuIqsM39jCOxAhQWXAjWMJftJXrBvp8bTORKPOq1nQ=="/><module name="WindowsPhone" url="https://gminstall.yoyogames.com/gm-studio/736665c7-2191-44d8-9d4f-de3cf88df1fa.zip" sparkle:version="1.4.9999" length="8504996" sparkle:dsaSignature="MCwCFGUwUu9FQ6rpaO51pg7QcuIcDciaAhQRrvA1Ilbu6vfEyZEmbdD9xBp5JA=="/><module name="WindowsUAP" url="https://gminstall.yoyogames.com/gm-studio/0d296f94-ebd6-458f-b2c9-bbcca6241b94.zip" sparkle:version="1.4.9999" length="36675401" sparkle:dsaSignature="MCwCFCOXJhbb038HSYWtsqZ8knQ8ihjTAhQgV7DyK/VD55Hl1uplK+57pA+U7g=="/><module name="XBoxOne" url="https://gminstall.yoyogames.com/gm-studio/6420318d-2576-4e30-a47b-b9ffb720ab94.zip" sparkle:version="1.4.9999" length="31969457" sparkle:dsaSignature="MC0CFQCJzkRw0ckzRTKxmKV3ROQ2SkZzcwIUR6jBHRG0JUaJapOT+x3sUuWEOl8="/></enclosure></item></channel></rss>

Step 3:
Save it as patch.xml

Step 4:
Type "run" into the start menu and open run.exe

Step 5:
Type in %APPDATA% and press Ok.

Step 6:
Open the folder "GameMaker-Studio" (full path: C:\Users\< your username>\AppData\Roaming\GameMaker-Studio)

Step 7:
Put patch.xml in there

Step 8:
Look for a file called "GameMaker-Studio.exe.config"
Make a copy of it and keep it somewhere safe.

Step 9:
Right click the original and select Open with.
Expand the menu and select Notepad. Uncheck "always use this app to open this file",

Step 10:
Look for:
Code:
<appSettings>
    <add key="Sparkle.SUFeedURL" value="http://store.yoyogames.com/downloads/gm-studio/update-studio.rss" />
    <add key="Sparkle.SUStableFeedURL" value="http://store.yoyogames.com/downloads/gm-studio/update-studio-stable.rss" />
Replace the url with file:///C:/Users/< your username >/AppData/Roaming/GameMaker-Studio/patch.xml
Make sure that where it says "< your username >", you put your computer's username.
If you're not sure what it is, go back to the GameMaker-Studio folder and at the top of the window, to the left of the search bar, click the bar to see the full file path.

So it looks like this:
Code:
<appSettings>
    <add key="Sparkle.SUFeedURL" value="file:///C:/Users/< your username >/AppData/Roaming/GameMaker-Studio/patch.xml" />
    <add key="Sparkle.SUStableFeedURL" value="file:///C:/Users/< your username >/AppData/Roaming/GameMaker-Studio/patch.xml" />

Step 11:
Save the file

Step 12:
Open game maker.

Still not working?
You could try using the newer version of the patch here.
Just follow the automated method steps again, only using that new code instead of the one listed.

And if it all went well:
SUCCESS.gif

Let me know what worked/ didn't work for you below
Code:
Download Error! The following modules could not be downloaded :
< modules >
Check your internet connection and restart GameMaker: Studio to retry. If problems persist, then contact http://help.yoyogames.com
Code:
"Unable to download RSS file to begin the download of missing modules!"
Code:
Stuck at: "Updating GameMaker-Studio Downloading... Preparing for download" forever.
 
Last edited:
Thanks man! looks pretty involved, but it's amazing you were able to not only figure out what the problem was but work out a fix for everyone! I will update my success with your troubleshooting steps as soon as I give them a try here in the next day or so.
 
Thanks man! looks pretty involved, but it's amazing you were able to not only figure out what the problem was but work out a fix for everyone! I will update my success with your troubleshooting steps as soon as I give them a try here in the next day or so.
Thanks! I'm glad I was able to help. I cannot take credit for the solution though, all the code that does the fixing was written by @emmyarty. I just put it into a tutorial!

How did it go? I'm assuming that as you haven't replied with any issues, it worked?
 
Top