GM:S 1.4 tile_layer_hide and tile_layer_show

Discussion in 'Legacy GameMaker Community Tech Support' started by DividingByZero, Mar 11, 2019.

  1. DividingByZero

    DividingByZero Member

    Joined:
    Jan 31, 2017
    Posts:
    494
    Hey all, quick question about how I am doing something. I am currently trying to animate some tiles in a background, so I have a two layers that I am stacking my frames of animation. I then have an object that basically cycles through tile_layer_hide and tile_layer_show for the top most of the layers.

    It seems to work well, no performance issues I can detect.

    My question is: Is there any problem with doing it this way I am not aware of?

    Like hidden performance issues, compatibility issues, etc... Or maybe there is just a better way to do it.

    Thanks!
     
  2. DividingByZero

    DividingByZero Member

    Joined:
    Jan 31, 2017
    Posts:
    494
    Well, I am not marking as 'solved', but I have been using this method now for a few days of dev - added some more toggling layers as well and all seems well. So, unless I hear otherwise - it seems like a legit solution.
     
  3. BaBiA Game Studio

    BaBiA Game Studio Member

    Joined:
    Jun 20, 2016
    Posts:
    708
    Edit: removed by me, as I didn't realise this was a 1.4.
    :)
     
    Last edited: Mar 14, 2019 at 7:55 PM
  4. DividingByZero

    DividingByZero Member

    Joined:
    Jan 31, 2017
    Posts:
    494
    Heh... yeah, I was hoping there was a more elegant solution in 1.4. Another good reason to upgrade to 2, which I will do eventually.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice