SOLVED The dreaded "Failed Run Program Complete" or "X://windows/Runner.exe exited with non-zero status (-1)"

So I've run into a snag following a tutorial where I go to run a program in the IDE to see that not much has changed, as it should be, and the window for the game does not appear. So, I go to run it again, and find that it, no it is running it's just not showing up. I then stop the run-time to see the Failed Run Program Complete about in the output. The Compiler errors is empty, and the only thing I could see as an error in the output is "X://windows/Runner.exe exited with non-zero status (-1)". Now, I've looked both up and have tried undoing code to what I had Yesterday, which it worked then. No luck. Then I've tried a full reinstall, nothing. Then, I've tried installing the runtime again. Nothing. I've tried running old projects that should work. Nadda. Restarted it many times.

So, should I just wait till it fixes itself with some update or try something else? Because I am running on the current build, 2.2.5.481, which is the most modern as of righting this, and it came out over three months ago, and this is the first I've seen of this problem. I've seen it mentioned that there are two compilers yyc and normal, however I read the normal one is used with the run button in the IDE, so I don't think the compiler is the problem. Unless somehow it switches compilers, which sounds like nonsense.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
I honestly can't say I've seen this issue other than when an inifinte loop is in the game start and prevents the window being shown to start with... however if it's doing this for new projects and other projects then this can't be the issue. My only real suggestion is to contact YoYoGames and request they help you, although it would also help us if you could post the FULL compiler outpur when you try to run a project, as it may be that there is something in that which will point us to where the issue is.

As for compiling, you can compile using the VM or the YYC by changing the target in the target manager (top right of the IDE, make sure you've got it set up right). You can test run with the YYC fine from the IDE, and it will only always use the VM when you run using the debugger.
 
Thank you Nocturne. Well, I would show you the outputs, but my computer's power died after going to bed last night, so I had to restart it. When I went back to check, it works. So, I can't exactly say what was the solution, maybe I needed the reinstall alongside a reboot, but I'll say it's solved for now, unless someone else has, had, or still has this bug when running with the run button.
 
Top