• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Mac OSX The Carbon driver has not been ported to 64bits


Ever since updating to OS Mojave, I've been getting this error when trying to run the game in VM.

EXCEPTION FILE - /var/folders/1m/g47rbvd15ds6rpndg7mr_vt40000gn/T/4593bdd1393f4b73a80ee0b252e08c2f.yyg.saencryptedreport
WARNING: The Carbon driver has not been ported to 64bits, and very few parts of Windows.Forms will work properly, or at all

/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono exited with non-zero status (82)

elapsed time 00:00:01.1366690s for command "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono" /Users/Shared/GameMakerStudio2/Cache/runtimes/runtime- -j=8 -options="/var/folders/1m/g47rbvd15ds6rpndg7mr_vt40000gn/GameMakerStudio2/GMS2TEMP/build.bff" -v -- Mac Run started at 09/21/2019 17:51:56
FAILED: Run Program Complete

I've tried reinstalling, which works SOMETIMES, and I've tried reinstalling MONO. Can't seem to figure out why this is happening all of the sudden.




I'm still on High Sierra but just got the "The Carbon driver has not..." error for the first time after installing 4 fairly large sprites (PNGs) into an asset layer. I deleted them and tried again and it worked, so, I'm not sure. If anything stands out as the reason why I'll mention it.