• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Texture Pages Bug

helpleo

Member
Hello everyone! I am putting the finishing touches on my first big Game Maker project, and I'm facing a very peculiar visual bug, which some other GM devs I know have also notices. It's simple; if the executable is minimized in windowed mode, when it is re-focused, it starts to flash random images from the game's texture pages in the screen.

Here are some examples my testers sent me:
https://www.youtube.com/watch?v=7ZaHAEUvFj4&f%20eature=youtu.be
http://imgur.com/a/dfNFU

The quasi-solution I have been adopting is using draw_texture_flush() when the game resolution or screen state changes, but this does not work for when the player alt+tabs the game, ou minimizes when playing on windowed. I have a nagging suspicion it might be due to to the fact that my game uses a truckload of visual assets but texture pages are completely disorganized (I have been working in this project since 2013, and I don't remember if texture pages were even implemented in GM Studio back then), or some other internal setting I might have overlooked.
 

Jaqueta

Member
Maybe it's this (It happened here on my potato notebook): Go to Global Game Settings>Windows>Graphics, and use the "Compatible" vertex buffer method instead of the Fast. This is very common to happen on Onboard Graphics cards, such as Intel HD 3000 and 4000 series.
You can also put this as an Option for the player if you want, by using the "display_set_windows_vertex_buffer_method" function.
 
R

renex

Guest
You can probably work around this by detecting focus loss with os_is_paused() and then flushing on the first input change detected after that (meaning the player refocused the game and is interacting with it).

Also try display_reset().
 

helpleo

Member
Hey guys, thanks for the answers! Apparently, the problem was far simpler than it looked, no code was needed; as Jaqueta guessed, my laptop also has a Intel onboard video card, and I did some further digging, as discovered this is a recurrent problem with theses kinds of machines.

The solution was simply deactivating "Force software vertex processing"; somehow, that is default configuration for Game Maker, even though the documentation deems it necessary only in extreme cases. Either way, problem fixed :)
 
Top