• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Legacy GM Studio Crash on Load-up (Error setting path: "rfPersonal")

Elijah Budd

Member
Hello. Thanks for clicking on my troubleshooting question instead of one of the many, many, many others.

So here's my fairly uncommon issue: Every time I try to open GameMaker Studio, it crashes immediately and throws this error:
rfPersonal crash.jpg

I couldn't find much about this on the internet, as the only reference to a "GameMaker rfPersonal" issue on Google was this forum page, but they never really have the issue fixed. They claim it was just working one day as they installed a little older build from the Beta Channel, which I tried to no avail. Same message popped up.

GameMaker Studio worked fine on my desktop for a few months after buying the Pro version, but then I got a trojan virus that just would not die. It was strange to get that, even, as I didn't download anything even remotely fishy. But anyway, I put important files into my Google Drive and reset the computer, doing a full reset too. Y'know, the one that takes 10 hours instead of 1 hour. After setting my few programs back up (Adobe's PDF reader, Google Drive/Chrome, Aseprite, etc.) I installed GM Studio, which worked for a few days. One afternoon I tried to open it and it threw this error. After researching and finding nothing, I've tried all of the following:
  1. Rebooting
  2. Reinstalling (after completely clearing the files)
  3. Installing different builds (Stable, Beta, and older)
  4. Clearing the %appdata%
  5. Bashing my head on the keyboard
TL;DR: GMS worked and now it doesn't.

Does anyone have suggestions on what to do? Theories on the issue? Do you know what rfPersonal even is? Any help is appreciated.



P.S. Until I can continue working on my game, I guess I'll go practice my pixel art. I've only been doing it for about a week, so it's not very good yet. While you're here, I'll take any pointers! I've resolved to get something out of this forum post. This is where I'm at:
pitcher.png Tetsu Mark 1, Person Base, Failed Walk Anim.png crappy walk animation.gif
(Pictured: pitcher.png, character test.png, crappy walk animation.gif)​
Any notes are appreciated, good or bad. Alright, I'm done ranting.

Cheers,
Elijah​
 
C

Chowderchu

Guest
@Elijah Budd I found a fix! I created a new user in Windows and now everything is working as normal. I think that the previous owner of the computer had GMS 1.4 installed and somehow it was creating the problem. Hope this helps!
 
Top