• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Stuck at building - (F5)

Lutist

Member
Hello im new with this software and making games in general. My experience is with RPG Maker and there building a game was easy and fast.
As context im following the "make your first game" tutorial
Here is what happens:

As i press F5 building starts. I have tried several times, each time never completing the process.
I have waited up to 30 minutes for it to build but to no avail.
I have attached a screenshot of how it looks.
I only have 4 sprites and 2 objects none of which contain any code at all.

The output is the following:
"cmd" /c subst Z: "C:\Users\Luis Malpica\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE"

elapsed time 00:00:00.0269458s for command "cmd" /c subst Z: "C:\Users\Luis Malpica\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE" started at 04/26/2020 15:51:21
"cmd" /c subst Y: "C:\Users\Luis Malpica\AppData\Local\GameMakerStudio2\GMS2TEMP"

elapsed time 00:00:00.0263455s for command "cmd" /c subst Y: "C:\Users\Luis Malpica\AppData\Local\GameMakerStudio2\GMS2TEMP" started at 04/26/2020 15:51:21
"cmd" /c subst X: "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.2.5.378"

elapsed time 00:00:00.0261899s for command "cmd" /c subst X: "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.2.5.378" started at 04/26/2020 15:51:21
Saving project to: D:\GMS2 Projects\Arcade\Arcade.yyp

My system is: Windows 10, 16GB RAM, Intel Core i7-8750H CPU 2.2GHz, with a Nvidia 1060 GTX 6GB, Driver 441.08, DirectX 12.

At the ending of this message the building has 10 minutes but there is no new window. I have also tried with the debug but its the same.
I have also tried turning off my firewall and antivirus. Still face the same issue.

I would greatly appreciate some help here.
 

Attachments

Slothagami

Member
I had this same problem when I first got gamemaker, it's not really explodes anywhere and it really should be.

What you need is to update your runtime, you go to file > preferences > runtime feeds > master, and check if you have the latest one downloaded and selected.

I don't know why this happens, and it goes automatically from there, it's just the first time, since I've never had that problem again.

It might be something else, this is just what fixed when I had the same problem.
 

Lutist

Member
Hey Slothagami, thanks for your response.
I am not sure if i have the latest runtime as I am new with this software.
I will leave a screenshot, maybe someone can tell if I do by seeing it.
 

Attachments

Top