Android Strange problems in my mobile game

Good morning people.

I have a problem with the internal test version of my new game for android. Making my game work on the mobile version is being the biggest challenge I've ever had when programming games. Every day is a new problem.

Google Play released my game for testing and I was the first to test it. I downloaded it to my cell phone and when testing, an object of another room appeared in a different room. A cube made for the campaign mode that is created from obj_player_ia that is on the campaign map is the only one that generates this cube. When running in battle mode which is a different room, the cube is created and the game crashes. The obj_player_ia object is only generated in the campaign room.

I tested the game in other circumstances. The results:
- I downloaded the internal test on Google Play and the error happened (aab);
- I generated a .apk in GM and installed it manually on the cell phone. THE ERROR DID NOT HAPPEN (apk);
- I ran the game in my cell phone (GM target). The error happened (apk);
- I ran the game on windows. The error did not happen (exe).

Note: I didn't change any lines of code in these 4 tests. I also noticed that the phone is not retrieving the data from the .ini file that I generated to save the game settings. On the PC, the .ini file works normally.
 
Well...
I discovered the problem: the YYC. When the game is transferred by the store or via cable by the GM, YYC messes up some elements of the game's structure. So an object in one room was being executed in another room. The order of the rooms was problematic too.
Why when I save the apk on the pc and install it manually, the YYC run perfectly? Without it the game runs very slowly on android. I'll have to see what to do.
 
Top