• Hey! Guest! The 40th (!!!) GMC Jam will take place between February 25th, 12:00 UTC to March 1st 12:00 UTC. Why not join in this very special anniversary jam! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Mac OSX Steam Intergration in VM (Solved....Sort of!)

knightshaft

Member
In High Sierra I could run my game in VM and test the Steam intergration. The game would run as expected, even if there was another version on the Steam server.

Now I'm using Catalina, the game runs but either the Steam intergration doesn't work or Steam tries to run/download the version on Steam. So I'm having to compile in YYC and upload each test.

Is this purely a result of Catalina's new security protocols (code signing everything) or have I messed up something else? Can I get Steam to work in VM on Catalina?
 

knightshaft

Member
I have seen multiple threads with this issue but no responses to any of them.

In High Sierra I get this but Steam works fine:

Code:
Error: Failed to load libsteam_api.dylib from  /Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.5.378/mac/YoYo Runner.app/Contents/MacOS/libsteam_api.dylib
dlerror:dlopen(/Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.5.378/mac/YoYo Runner.app/Contents/MacOS/libsteam_api.dylib, 1): image not found
In Catalina I get the above, followed by this and steam fails:

Code:
Error: Failed to load libsteam_api.dylib: dlopen(/Users/scottcooke/Library/Application Support/com.yoyogames.macyoyorunner/game/assets/libsteam_api.dylib, 1): no suitable image found.  Did find:
    /Users/username/Library/Application Support/com.yoyogames.macyoyorunner/game/assets/libsteam_api.dylib: code signature in (/Users/username/Library/Application Support/com.yoyogames.macyoyorunner/game/assets/libsteam_api.dylib) not valid for use in process using Library Validation: mapping process and mapped file (non-platform) have different Team IDs
Failed LoadSteamLib() call: Error loading libsteam_api.dylib
SteamInit failed: Error loading libsteam_api.dylib
It says no image for libsteam_api.dylib then says it found an alternative (but the path is the same) but it can't be used becuase its for a different team ID (err....no!)
 

knightshaft

Member
Seems to be a bug related to this

 

knightshaft

Member
I worked out late yesterday that the libsteam_api.dylib file used in VM comes from within GMS2 NOT the Steam SDK. Bug Support said this:

"VM works by using a pre-built executable and just swapping out the data file it loads, which is why it's using a different Steamworks package and the codesigning isn't correct"

"There is nothing we can do about this, and we're in the same situation as we have to send every build of GMS2 off to Apple also"
 
Top