1. Hey! Guest! The 32nd GMC Jam will take place between Feb 22nd, 12:00 UTC (Friday noon) and Feb 25th, 12:00 UTC (Monday noon). Why not join in! Click here to find out more!
    Dismiss Notice

Mac OSX Steam features not working

Discussion in 'Programming' started by JAG, Feb 12, 2019 at 8:38 PM.

  1. JAG

    JAG Member

    Joined:
    Jul 5, 2017
    Posts:
    73
    Hi there, Im trying to add Steamworks features to my game, but I can't get the overlay to pop up when I run on my Macbook. I've even created a brand new project just to test the Steam integration in isolation, and still cannot get it to work. I run the game, I expect to see the overlay pop up (and to be able to trigger it with Shift + Tab) but nothing happens.

    Im following these steps:
    1. Create a new project
    2. Point GM at my Steamworks sdk folder location (sdk version is 1.42)
    3. Check "Enable Steam" in the macOS platform settings
    4. Add ID 480 to the "Steam ID" field in general settings (I have been told this ID will work for testing purposes, so Im using it instead of my actual app id)
    5. Uncheck the "Build for Mac App Store" option in macOS Packaging settings
    6. Run the app

    The result is that nothing happens, the steam toast doesn't pop up. Here's the section of output logs that might be relevant, please let me know if you have any ideas about what could be causing this issue. Thanks!!

    Code:
    HighScore..filename is /Users/jimmy/Library/Application Support/com.yoyogames.macyoyorunner/hiscore.dat
    Game..Math..Graphic..Action..File..Resource..Interaction..3D..Particle..Misc..DS..Sound..Physics..Gamepad..Attempting to set gamepadcount to 4
    libYoYoGamepad.dylib found at path /Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.1.291/mac/YoYo Runner.app/Contents/MacOS/../Frameworks/libYoYoGamepad.dylib
    Buffers..Networking..Shaders..steamfile:/Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.1.291/mac/YoYo Runner.app/Contents/MacOS/steam_appid.txt
    Steam_Init
    Error: Failed to load libsteam_api.dylib from  /Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.1.291/mac/YoYo Runner.app/Contents/MacOS/libsteam_api.dylib
    dlerror:dlopen(/Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.1.291/mac/YoYo Runner.app/Contents/MacOS/libsteam_api.dylib, 1): image not found
    Steam - SteamAPI_RestartAppIfNecessary
    Steam - Steamworks_InitCEGLibrary
    Steam - SteamAPI_InitSafe
    Steam - SteamApps()->BIsSubscribed()
    Steam - SteamClient()->SetWarningMessageHook()
    Steam - Steamworks_SelfCheck()
    Steam - Steam_UserStats_Init()
    Steam - Steam_RemoteStorage_Init()
    Steam - Steam_Screenshots_Init()
    Steam - Steam_Friends_Init()
    Steam - Steam_UGC_Init()
    Logged in steam user id 76561198044744584
    Found 0 subscribed items
    g_bSteamInitialised being set to trueSteam_Init
    LoadSteamLib and _steamInit both ok
    InitPushFunctions...YoYo..filename is /Users/jimmy/Library/Application Support/com.yoyogames.macyoyorunner/playerachievementcache.dat
    Fini
    
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice