• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows SSH Source Control With GitLabs

Anyone out there using GitLabs over SSH for source control? No matter what I tried I couldn't get the key to authenticate, though maybe I am doing something wrong. Normal HTTPS works fine, but I would prefer keys since that is how I handle most of my authentication on other projects.

First I tried setting up keys in GitBash, the first one being ED25519 but after not authenticating properly I suspected that GMS may not support that key type yet since it's relatively new. Then I created a typical RSA key which should be supported, but it also wouldn't authenticate. Next, I tried letting GMS2 generate the keys, but even that wasn't working. And, just to clarify, I was adding the public keys to GitLabs, and I tried both with and without passphrases.

I'm guessing that I am either missing something, or that perhaps it just doesn't work with GitLabs?

Windows 10 64bit
GMS2 | IDE 2.2.5.481 | Runtime 2.2.5.378
 

FrostyCat

Member
Try it with command-line Git or TortoiseGit first, before you try the Git integration built into GMS 2. The latter has been such a pain point for so many users that most of them are now working off the command line exclusively. You also need to make sure nothing else has gone wrong with your setup before pinning the blame on GMS 2.
 

Dolriis

Member
I second that.
The built-in Git plugin doesn't seem to work.
The error logging is lackluster, and there is a 3 year old post quoting similar, unsolved behaviour.
Commandline Git or GitHub Desktop is probably the way to go.
 

samspade

Member
I also agree. I never interact with git inside of GMS 2 (not even to initialize) as I had too many issues (freezing, lockups, error messages, etc.). I have been using git in the command line only (with git bash) for a year now at least and have had zero issues (I only use git for single branch backups nothing fancy).
 
Top