GML Sprite not appearing issue

I'm having an issue relating to my sprites / objects not appearing.
My issue: I'm trying to create a new object, the code is all fine. I place it in the room but it doesn't appear in-game.

Other existing objects appear perfectly fine. I had a slight hunch that none of my new objects would appear (for some reason, idk why), so I duplicated one of the working objects. I didn't change anything in the duplicated object, and I then placed that in the room. However, the duplicated version of the otherwise working object didn't appear either; leading me to think that i just can't create new objects at all?

I can still place the original object and that appears fine in game. Basically, I can use my existing objects fine, but when I try to create a new one, it somehow breaks and just doesn't appear in-game.

Any ideas of what i could try?

Thanks!

EDIT:

Sorry - it might help if I give some more info.
- My objects do have a draw event; but I have got the draw_sprite_ext() function in them properly.
- I haven't changed anything in the duplicated object, it is exactly the same as the original. Therefore i have no idea why the duplicated version is not appearing when the original is.
- i'm following a tutorial series step by step, none of the code or objects are different from the tutorial

And here's a few other bits of info that might be relevant but i can't see how they would be:
- I tried to implement basic particles today (and this is where i noticed it - the particles weren't appearing when i placed them, even though they should have at that point)
[as a side note, i deleted everything relating to the particle stuff but this didn't solve the issue]
- i created a new project yesterday; i also renamed this project at the same time (also, the new project has the same title as the old name for this project, and i created the new project because i decided i'd not do everything according to the tutorial if i were to make my own game - i'm following the tutorial in this project)
- i only noticed this issue today

I'm not sure any of my code will help out since again I have the situation where the original objects work but the duplicated one doesn't. Though I'll provide it if necessary. :)

EDIT 2:
I was thinking about the fact that i had changed my project title; so I looked into the project directory and somehow there were two projects in there? I guess i was working on the current project but the game was running off the old project or something. Deleted the old version.

Anyway, problem solved! I suppose this post is kinda useless now, but I honestly had no idea that renaming project files would cause issues like this.
 
Last edited:
Top