Spine animation issue: it only intepolates at default anim speed.

Discussion in 'Legacy GameMaker Community Tech Support' started by Gamely, Dec 22, 2016.

Tags:
  1. Gamely

    Gamely Member

    Joined:
    Dec 16, 2016
    Posts:
    25
    If you change image_speed to something slower than 1 you don't get any motion interpolation as it still interpolate at predefined rate.This still apply if you draw the skeleton by the drawing api.

    This just looks as spline animation are not interpolating at all at runtime, but get preinterpolated.
    This makes spine use a lot less sexy.

    tested on 1.99.535 with suggested spline version.
     
  2. JaimitoEs

    JaimitoEs Member

    Joined:
    Aug 9, 2016
    Posts:
    112
    Mmmmm i think that is correct, i tried this 2 years ago and i don´t remember correctly so maybe i´m wrong :

    The main problem is how gamemaker handle Spine interpolation, gamemaker is step based and Spine runtime is delta time based, try to put a very high roomspeed and make the test again to see what´s happend.....

    You can make a Slowmotion control using a delta time system.

    Another way is with the function "draw_skeleton_time" to control the animation with your own time system, but i´m not tried this at the moment.
     
    Last edited: Dec 23, 2016
  3. Gamely

    Gamely Member

    Joined:
    Dec 16, 2016
    Posts:
    25
    Thanks for your suggestion I ve got draw_skeleton_time a second chance and it failed again with the same issue.
    Also Deltatime workflow doesn't fix the problem plus it is not an option as deltatime is just an hack in game maker and isn't compatible with many systems like particles and alarms and breaks determinism .
     
  4. JaimitoEs

    JaimitoEs Member

    Joined:
    Aug 9, 2016
    Posts:
    112
    Yes, i know the Delta timing issues with projects, just suggested this to show you interpolation works with imagen speed lower than one , with high room speed...
     
  5. JaimitoEs

    JaimitoEs Member

    Joined:
    Aug 9, 2016
    Posts:
    112
    Another easy way is scale your time in the Spine project, giving more seconds and then set a high imagespeed in gamemaker like 2 or 3, and then low this when yo need.
     
  6. Gamely

    Gamely Member

    Joined:
    Dec 16, 2016
    Posts:
    25
    This is a way better hack as it doesn't interfere with other system.
     
  7. Gamely

    Gamely Member

    Joined:
    Dec 16, 2016
    Posts:
    25
    Thanks This is a way better hack as it doesn't interfere with other systems.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice