1. Hey! Guest! The 34th GMC Jam will take place between August 22nd, 12:00 UTC (Thursday noon) and August 26th, 12:00 UTC (Monday noon). Why not join in! Click here to find out more!
    Dismiss Notice

GM:S 1.4 Some UTF8 characters will not draw

Discussion in 'Programming' started by Aleksandar Gavrilovic, Jun 26, 2016.

  1. Aleksandar Gavrilovic

    Aleksandar Gavrilovic Member

    Joined:
    Jun 20, 2016
    Posts:
    82
    I want to draw characters like these:
    ⌒_⌒
    ^ω^
    (o︶︹︺)
    (」゜ロ゜)」

    I made a font and added the appropriate ranges for all the neccessary characters. Unfortunately, not all of them are visible in the font (I tried other fonts, but the problem persists)

    Here are the font ranges
    <range0>32,127</range0>
    <range0>180,180</range0>
    <range0>201,201</range0>
    <range0>233,233</range0>
    <range0>968,969</range0>
    <range0>1044,1044</range0>
    <range0>1076,1076</range0>
    <range0>3665,3665</range0>
    <range0>7509,7509</range0>
    <range0>8226,8226</range0>
    <range0>8411,8411</range0>
    <range0>8704,8704</range0>
    <range0>8978,8978</range0>
    <range0>9581,9582</range0>
    <range0>9661,9661</range0>
    <range0>9663,9663</range0>
    <range0>9696,9696</range0>
    <range0>9825,9825</range0>
    <range0>10023,10023</range0>
    <range0>10075,10075</range0>
    <range0>12301,12301</range0>
    <range0>12494,12494</range0>
    <range0>12541,12542</range0>
    <range0>65077,65078</range0>
    <range0>65081,65083</range0>
    <range0>65344,65344</range0>
    <range0>65374,65374</range0>
    <range0>65439,65439</range0>
    <range0>65507,65507</range0>

    The font I would like to use is Gargle Rg, but for these characters, actually, any font would be OK, if they worked. As you can see from the attached image below, some of the characters within the range are shown in the bottom-right corner as inserted by the font, but they are not in the image (and they are not drawn on screen when I try drawing them with draw_text).

    I tried clearing the asset cache, I don't use surfaces etc. Help would be appreciated, thank you :)
     

    Attached Files:

  2. FrostyCat

    FrostyCat Member

    Joined:
    Jun 26, 2016
    Posts:
    4,327
    Duh, not all of the characters are visible in the font because the font doesn't have glyphs for all of them. In particular, artsy non-standard fonts tend to be skimpy in glyph coverage. Open the font in Character Map and make sure the corresponding glyph is in it before you try adding them.
     
    Aleksandar Gavrilovic likes this.
  3. Aleksandar Gavrilovic

    Aleksandar Gavrilovic Member

    Joined:
    Jun 20, 2016
    Posts:
    82
    Ah, I thought maybe it would just take the glyphs from another, more default, font... Can you recommend a font which has most / all of the gliphs I need? I can't seem to find one.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice