• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

iOS SOLVEDPorting to IOS/Mac Troubleshooting (GMS1.4)SOLVED

G

Guy_Typing

Guest
Hello fellow game designers. I have a game that I have been working on and am planning on releasing
to mobile platforms. Android I've got taken care of and out of the way. Now I am currently trying to
export my game to IOS products specifically Ipad and Iphone.

I've already consulted this guide here:
https://help.yoyogames.com/hc/en-us/articles/216753858-Develop-For-And-Distribute-To-iOS
as well as this guide here:
https://help.yoyogames.com/hc/en-us/articles/216753538-Develop-And-Distribute-To-Mac-OS-X
and I will continue to sift through them to find anything I have missed.

When I run the game with a MacOSX as target I can play the game on my Mac.

When I create an executable for MacOSX and place it on my Mac desktop and run it, it crashes
immediately. The termination reason is Namespace CODESIGNING, Code 0x1. I should mention that the
crash message isn't your typical yoyo runner crash message but instead appears to come from the mac
OS.

For IOS when I create an executable for target I end up getting a prompt that says "Project
/Users/Myname/gameMaker-Studio/GameName/GameName/GameName.xcodeproj cannot be opened because the project file cannot be parsed."

Both my Mac and my Ipad have provisions profiles, verified by xcode when I go to window and select
devices and yes my Ipad is connected to my Mac.

My macbook OS is Sierra version 10.12.6

My xcode version is 8.3.3

For apple certification I have the following:
-----IOS---------
-ios Development
-ios Distribution
-app id
-provision profile
-----MAC---------
-Developer ID Application
-Developer ID installer
-Mac Development
-Mac App Distribution
-Mac Installer Distribution

The IOS hurdles are the last I have to go through before being able to release my game to the
public. If anyone can help me here you would be doing a great thing for me.

Please Help!

Update: Okay, so I was able to get this working on my Mac. The issue with the Namespace CODESIGNING has been resolved so I only have the IOS issue remaining. The solution to the code signing issue was found here https://www.reddit.com/r/gamemaker/comments/63iu8x/gamemaker_game_crashes_on_mac_os_x_1012x_sierra/
What I did was this. I created the executable from gamemaker on my pc to my mac desktop and tried running it which is when I received the CODESIGNING issue. What I did is, following the advice from the link, I held the control key on my macbook and mouse clicked the executable, which I'm pretty sure is equivalent to a right mouse click. I then selected the option "Show Package Contents" and it revealed a folder called "Contents" which I clicked on. In that folder was the _CodeSignature folder and when I deleted that and then clicked on the executable again (with the left click) the game ran.

So that resolves the CODESIGNING issue but I still have the more important issue at hand for the IOS port which is "cannot be opened because the project file cannot be parsed." error. So if anyone can help with that still it will be greatly appreciated. I will keep working on it as well and if I find a solution I will post it here.

Double Update: In trying to problem solve the IOS issue I've stumbled upon something very strange. Holding control and clicking the mouse on the .xcodeproj and then clicking show package contents I found a file called project.pbxproj. When I click on that and look at the contents there is something very strange. There is a whole plethora of code referencing a GMS2 Project I worked on. In fact most of the code in this file references objects and such from that project. The strange thing is, the game I'm trying to port to IOS is a GMS1.4 project and it's not even the same project. Can some one in the know tell me how in the heck this stuff ended up in this file?

Triple Update: Okay so in regards to that last update I think I figured out the issue. I'm not sure how or when this happened but some how some way a couple of projects from my repository were included in the included files on the assets tab of GMS. I have absolutely no idea how this happened, it's extremely perplexing. Furthermore, upon removing these included files and also the data files in the folder created from the included files, I find that xcode was seemingly able to parse my project so I should be able to take it from here. I'm going to mark this as solved.
 
Last edited:
Top