GMS 2 solved - "Unable to find any instance for object index" for a true/false variable

SOLVED
GMS2 error report fails if the instance turning up an error does not exist.

I am getting the following error:

Unable to find any instance for object index '100107'
at gml_Object_obj_vent_Step_0 (line 18) - if process_checking_room {

on the following lines:
Code:
   //continue room checking process or finish it
>> if process_checking_room {
       if room_size_prev != room_size {
           //continue process
           room_size_prev = room_size;
The problem is, I've checked with the debugger, adn the variable "process_checking_room" is only ever true or false, 0 or 1. I'm at a loss, the error report is telling me about a bug that isn't where it should be...
In the debugger, a certain object has an id of '100107', however, it is not the object putting up the error.

Have any of you experienced any similar bug?
I've tried:
-Cleaning the project
-Restarting the IDE
-Checking the variable with the debugger:
no reference to any '100107' in any variable near the error's line.
-Copying the code to a notepad, deleting the obejct, saving, creating the object again.
-Wrapped all references to the obejct most likely to be referenced as '100107' with:
Code:
if (reference_to_100107 != noone) { /*do stuff*/ }
Any ideas?
 
Last edited:
Top