Android [SOLVED] Testing game on Android failed build

JoltJab

Member
Game Maker 1.4

Hey! I'm trying to test my game on my android phone but I keep getting this compile error.

I think I have all the SDK NDK and JDK stuff set up correctly, but I'm not sure. I also have my phone set to developer mode with USB Debugging check on. I tried looking up what stacktrace is, but all I found were people with similar but different problems. A lot of this stuff feels a bit over my head.

-------------


FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring project ':com.companyname.Slopes_Maths'.
> failed to find target with hash string 'android-23' in: C:\android-sdk

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 4.665 secs
cmd /c "subst /d Z:"

Lint Build report available at C:\Users\Thomas Hardy\Documents\GameMaker\Cache\SaveTheHero_169\Android\Default\com.companyname.Slopes_Maths\build\outputs\lint-results.html
FastCreate End End: 10:01:45 PM
Compile finished: 10:01:45 PM


--------------

anyone have any ideas?
 
Last edited:
G

Guest

Guest
Well, since someone who knows what they're talking about hasn't answered...

The "23" looks like the default SDK, build tools, and support library settings in your project, in Options, in Android, under General. You probably have newer versions of these. I'd tell you to follow the YYG documentation, but it's out of date and I had trouble in this particular area. So I'll tell you what I've put in those fields, using the most recent versions of the SDK etc. that I was able to download last week:

Build Tools: 26.0.0
Support Library: 26.0.0+
Target SDK: 26
Minimum SDK: 14
Compile SDK: 26

So, the "+" plus sign. Apparently you're not supposed to use that because it's sloppy. However, the actual version of my support library was something something "-alpha." I could not add the "-alpha" suffix, or it didn't work with that added, and it did not work using the version number without the "alpha." So, I used the plus sign, and it works.

If that doesn't work, then squint closely at the documentation and go through everything again:

https://help.yoyogames.com/hc/en-us/articles/115001368727-Setting-Up-For-Android

Edit: I just squinted closely at your OP and see you're using GMS1. No idea about that. I'm on GMS2.
 

JoltJab

Member
I gave it a shot but no good. Same error except instead of the "23" it's now a "26". I appreciate the try though! And yeah it's GMS1 but thanks for the help!
 

FrostyCat

Member
I gave it a shot but no good. Same error except instead of the "23" it's now a "26". I appreciate the try though! And yeah it's GMS1 but thanks for the help!
Then keep at it and install API 26 as well.

Common sense reminder: If the compiler tells you it is missing component X, install component X and try again.
 

JoltJab

Member
You download the API 26 or 23 through the SDK manager right? Well that's a problem for me because the download didn't seem to include it.

I've been looking everywhere but I can't get my hands on an SDK manager. The website that lets you download the SDK stuff (listed in the guide: https://developer.android.com/studio/index.html#Other) has "Android Studio" (which doesn't open the SDK manager after install, or install it) but at the bottom has the SDK tools package, which is just a folder of a lot of things I don't understand. However, in the \tools\bin folder there is a file called "sdkmanager" but on clicking it, it doesn't really do anything. It just pops up the cmd thing and closes back down.

Thanks @Kyon and @FrostyCat. I feel like I'm close but tripping at the finish line.
 
G

Guest

Guest
When you start Android Studio:

If you get a welcome screen, click Configure, SDK Manager.

If you do not get a welcome screen but instead are dumped into your last project, click Tools, Android, SDK Manager.

Edit: There's no particular reason you should have a last project (or any project) or be dumped into it, except that, as far as I can tell, there's no way to access the GUI interface for managing AVDs except by making a project in Android studio and accessing it through Tools, etc. within the IDE.
 
Top