• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

UWP [SOLVED] - SUCCESS: Run Program Complete but UWP game does not run.

I have had many issues with getting UWP working on GMS2 however when I finally got there I got the strangest of all errors. The game signed the certificate to the game, created all the objects everything but when it runs the game, it shows the splash, then immediately quits and shows: SUCCESS: Run Program Complete. There are no compiler errors or warnings of any kind but its like its just not building the .appx file at all. My certificate is up to date I have VS2017 with the Windows 10 SDK: 10.0.17763.0. And still nothing. Running the game on Windows output works fine. I even tried building the project fully and running it on my PC and Xbox with the exact same result no error message or anything. I really don't understand what's going on.

NOTE: I did create a ticket about this to YoYo Games and they asked me for some data to help with the diagnosis which I sent. That was two weeks ago and I've heard nothing since. :( I cannot provide certain info about game certificate etc but I can provide some so please let me know if more info is needed! Thanks for reading!
 
Last edited:
Nope unfortunately not. I tried this (I used the same certificate as I don't want to go through that mess again) but the same issue persisted. (Please note I live in the UK and it's like midnight so I may go to sleep but I will be able to try methods suggested tomorrow) Thanks for the suggestion

I also tried asking the discord server with no responses on there too so I'm actually really glad you noticed this!
 

rIKmAN

Member
Can you compile a new empty project using the default certificate and settings as they are when left untouched after installing GMS2?
 
Yep just tried that and got the same result again. The weirdest part is no errors appear meaning it's near impossible to diagnose

However I have noticed some other things which may be useful. I set it so that my program starts in full screen mode and with UWP that doesn't happen. Plus my game is 1920x1080 and it doesn't appear close to that size when the splash appears regardless.

If all else fails I may tonight uninstall VS2017 plus all the SDKs and reinstall them to see if that does anything.
 
Last edited:

rIKmAN

Member
Yep just tried that and got the same result again. The weirdest part is no errors appear meaning it's near impossible to diagnose

However I have noticed some other things which may be useful. I set it so that my program starts in full screen mode and with UWP that doesn't happen. Plus my game is 1920x1080 and it doesn't appear close to that size when the splash appears regardless.

If all else fails I may tonight uninstall VS2017 plus all the SDKs and reinstall them to see if that does anything.
If there is no error message then it's going to be pretty hard to diagnose, although I can say that UWP Desktop works fine for me with my own project and an empty room project which both use the default certs, so I don't think the issue is with the export so much as your specific setup - especially if you can't even compile an empty room project.

I had issues connecting to my XB1 but that is a seperate known bug and unrelated to your issue, once I get chance to test it again and remove the username/password authentication it will work based on others users feedback of making that change

Can you compile an empty VS project to both Desktop and XB1, removing GMS2 from the equation?
Have you tired starting from fresh and following the setup guide for UWP Desktop?

If compiling from VS works without an issue then I think your best bet is to wait to see what YYG say with regards to your logs and extra info you supplied, although I realise that might not be what you want to hear due to the lack of speed in their responses.
 
Ok I tried that on VS2017 and got this error message:
Error File 'MakePri.exe' not found. See http://go.microsoft.com/fwlink/?LinkID=798187 for more information.
Going to that site asks me to reinstall the SDKs so once I actually wake up I'll try that.

Idk what that file is because I'm not too technical with this stuff but the fact it has the word 'make' in it makes it seem important

Ah that might be another reason. VS2017 needs an update apparently
 
Last edited:
Update: So I'm currently installing the SDK and VS has decided to use an older SDK this time: 10.0.17134.0. Also I found the file VS2017 was complaining about and it's well, in the correct place as far as I can tell.

Nope I'm still getting the same thing with GMS2 and VS2017. I'll try uninstalling VS and restart from the beginning but if that fails I think Microsoft Support may be the way to go with this one
 
Last edited:
Ok I'm sooooooo close! I got the empty room to run on UWP however when I try to run my game I get this in the output right after signing:

System.Exception: unable to install app on device
at Igor.WinUWPBuilder.DoInstall(String packageFullName, String appx_path, String certificate_path)
at Igor.WinUWPBuilder.BuildWindowsUAPProject(String package_name, String _targetfile, Boolean _final)
at Igor.WinUWPBuilder.Run()
Igor complete.

Any idea what causes this?
PS: The empty room uses the default certificate whereas my game uses the certificate for my app listing. I would rather keep that app certificate since I'm going to need to reapply it at some point
 
Last edited:

rIKmAN

Member
Ok I'm sooooooo close! I got the empty room to run on UWP however when I try to run my game I get this in the output right after signing:

System.Exception: unable to install app on device
at Igor.WinUWPBuilder.DoInstall(String packageFullName, String appx_path, String certificate_path)
at Igor.WinUWPBuilder.BuildWindowsUAPProject(String package_name, String _targetfile, Boolean _final)
at Igor.WinUWPBuilder.Run()
Igor complete.

Any idea what causes this?
PS: The empty room uses the default certificate whereas my game uses the certificate for my app listing. I would rather keep that app certificate since I'm going to need to reapply it at some point
I've only used the default certificate so far and had no issues, so can't help much with that.

Maybe have a read through this GMS2 guide on Preparing Your UWP App For Publishing which has a section on generating your own .pfx signing certificates etc, though I'd recommend going through it from the start rather than halfway through just to rule out issues that could cause.

At least now you know your tools are working as the empty room compiled successfully, so we've made progress.
 
Hi! Sorry I didn't reply for a while I had some stuff I had to do. Anyways I found the issue with that error. I previously built the program as a test and installed it and GMS2 couldn't uninstall it. Also glad you told me about that Xbox One bug because I was wondering why I couldn't do it! Everything works now apart from building (which I have yet to test) anyways thanks for your help! :)
 
I can build for UWP no problem but when trying to debug a UWP project all I get is a black screen and the debugger never connects. I've contacted YoYo but not had a response in over 3 months I'm sure they forget they charge people for their software. Starting to think YoYo is the software worlds version of a cowboy builder.
 
Last edited:
Top